[Bug 63821] SyntaxError when byte-compiling for python2.5

Francisco Borges francisco.borges at gmail.com
Tue Oct 3 20:13:52 BST 2006


Public bug reported:

Binary package hint: python-gtk2

Hello,

I'm running Edgy, have python2.5 installed and just ran an update.

I got this from python-gtk2:

Setting up python-gtk2 (2.10.2-0ubuntu1) ...
Compiling /var/lib/python-support/python2.5/SOAPpy/Client.py ...
  File "/var/lib/python-support/python2.5/SOAPpy/Client.py", line 46
    from __future__ import nested_scopes
SyntaxError: from __future__ imports must occur at the beginning of the file

Compiling /var/lib/python-support/python2.5/SOAPpy/GSIServer.py ...
  File "/var/lib/python-support/python2.5/SOAPpy/GSIServer.py", line 49
    from __future__ import nested_scopes
SyntaxError: from __future__ imports must occur at the beginning of the file

Compiling /var/lib/python-support/python2.5/SOAPpy/Server.py ...
  File "/var/lib/python-support/python2.5/SOAPpy/Server.py", line 46
    from __future__ import nested_scopes
SyntaxError: from __future__ imports must occur at the beginning of the file

Compiling /var/lib/python-support/python2.5/SOAPpy/Types.py ...
  File "/var/lib/python-support/python2.5/SOAPpy/Types.py", line 39
    from __future__ import nested_scopes
SyntaxError: from __future__ imports must occur at the beginning of the file

** Affects: pygtk (Ubuntu)
     Importance: Undecided
         Status: Unconfirmed

-- 
SyntaxError when byte-compiling for python2.5
https://launchpad.net/bugs/63821



More information about the desktop-bugs mailing list