[Bug 36539] The eject button on the CD-Drive does not work for data CDs

Luna-Tick lists at whitehouse.org.nz
Wed Mar 29 18:25:59 UTC 2006

Public bug reported:

Affects: gnome-volume-manager (Ubuntu)
       Severity: Normal
       Priority: (none set)
       Assignee: Martin Pitt
         Status: Needs Info

Dapper Flight 5 - Fully updated. I use a Dell Inspiron 510m, hardware ID:
(I can't find it any more! Where has it gone in Dapper???)

If a data CD is in the drive, one cannot eject it by pressing the button
on the CD drive. With an audio CD it works as expected. My guess is that
it has something to do with unmounting the volume (which isn't necessary
for the audio CD).

In Breezy the button on the CD drive worked correctly for audio CDs but
did nothing for data CDs, unless the volume was unmounted and then the
eject button on the drive worked as it should.

If the icon is right-clicked then a dialogue appears saying "writing
data to removable device" (a scary thing to see when it is a CD you
don't want to write to...) and then the eject works correctly. If the
eject hotkey (Fn+F10 for me) is pressed, then there is no dialogue box
and it just ejects the CD.

My suggestion to solve this issue is to make the routine called in the following instances:
- right-clicking the icon and choosing eject
- pushing the button on the CD drive
- pressing the hotkey for eject
exactly the same. Surely it would be better to have them all use the same code and just get that code correct.

Any questions, just ask.

More information about the desktop-bugs mailing list