[Bug 37134] unable to add network-printer using the same driver

Christian Göbel christiangoebel at web.de
Wed Mar 29 08:35:11 UTC 2006

Public bug reported:

Affects: gnome-cups-manager (Ubuntu)
       Severity: Normal
       Priority: (none set)
         Status: Unconfirmed

Using ubuntu Dapper (with the latest updates 29/03/2006) in an office
environment I observed the following problem:

Using System / Printing (gnome-cups-manger) did not allow me to add a
network printer. The problem seems to be that there are several printers
at different location which all use the same print driver. When
selecting the printer (driver) NO new printer has been added to the
print dialog.

Possibly this is a problem of naming since the following worked:
1. Adding a printer using the wrong/different driver (driver-name) did the job - a new printer has been added.
2. Then it is possible to choose the correct print-driver from the properties of the new printer.
3. Printer worked.

It seems that this is a naming problem: gnome-cups-manager seems not to
be able to create a new printer with the same name.

In addition it is not possible to change the printer-name or the
location (via properties in the gnome-cups-manager) which makes it hard
to distinguish printers.

Possibly this is related to the following bug:

This is a major problem in an office environment since typically the
same printers are used at different places - and the user cannot easily
add/distinguish printers.

More information about the desktop-bugs mailing list