[Bug 33549] evolution doesn't shutdown when Draft, Junk, Sent items, Trash e-mail folder is selected

Olivier Poulet opoulet at hispeed-sr.ch
Fri Mar 3 23:06:46 UTC 2006


Public bug report changed:
https://launchpad.net/malone/bugs/33549

Comment:
I may not be doing things right, but gdb isn't giving what I think would
be useful results... I do know how to interrupt gdb if I do "gdb
evolution", and if I attach gdb to the existing process, I still need to
kill evo. And I get the following (shortened output). The bt command is
issued after having killed evo.

---Type <return> to continue, or q <return> to quit---
(no debugging symbols found)

(evolution:32376): evolution-mail-WARNING **: ignored this junk plugin:
not enabled or we have already loaded one

(evolution:32376): e-utils-WARNING **: Plugin 'Bogofilter junk plugin' failed to load hook 'org.gnome.evolution.mail.junk:1.0'
(no debugging symbols found)
(no debugging symbols found)
(no debugging symbols found)
(no debugging symbols found)

(evolution:32376): camel-WARNING **: camel_exception_get_id called with NULL parameter.
[New Thread 1082132832 (LWP 32381)]
(no debugging symbols found)
[New Thread 1090525536 (LWP 32382)]
[New Thread 1098918240 (LWP 32383)]
[New Thread 1107310944 (LWP 32384)]
[Thread 1098918240 (LWP 32383) exited]
(no debugging symbols found)
[New Thread 1098918240 (LWP 32385)]
[Thread 1090525536 (LWP 32382) exited]
(no debugging symbols found)
(no debugging symbols found)
[New Thread 1090525536 (LWP 32389)]
[New Thread 1115703648 (LWP 32390)]
Cannot find user-level thread for LWP 32376: generic error
(gdb) bt
Cannot fetch general-purpose registers for thread 1098918240: generic error
Cannot fetch general-purpose registers for thread 1098918240: generic error
(gdb) quit


What I can give as additional information:
- I've been dragging along this mailbox since evo 0.9 (roughly)
- It contains ~ 500 mails
- I have disabled the bogofilter plugin, as it conflicts with the spamassin plugin, and I have spamassissin well trained
- Evolution checks the mailbox (pop) every 10 minutes.

I still have evolution segfaulting (ir)regularly on exit, and think this
could be a strange interaction between me wanting to exit, and evo
checking for new mail and/or passing a message to spamd

If there's something else I can do, please ask.




More information about the desktop-bugs mailing list