[Bug 49993] Abiword occasionally corrupts RTF documents

Dan V bigdan at gmail.com
Fri Jun 16 14:04:21 UTC 2006


Public bug reported:

Binary package hint: abiword

Unable able to consistently reproduce, but this has happened to me twice in the past 24 hours. The exact steps that happen are that I'm editing a fairly complex and big rtf document, saving quite a bit (every major change), and so on.
Eventually, I start to see slow downs (times when the mouse is almost laggy or applications aren't switching very fast), so I save my document and exit abiword immediately. When I reopen abiword and try to open my document I was editing I get "Error importing file: <filename>.rtf". <filename>, of course, was the file I was editing.

The first time this happend I just opened it in gedit and was able to
recover my text. The second time this happened I vi'd the file and
compared it to a good rtf I just made in abiword. The now corrupted RTF
contained this at the very bottom:

\pard\plain\ltrpar\ql\sl240\slmult1\intbl\itap1{\f1\fs20\lang1033{\*\listtag0} $40,950.00}\cell{\*\abiendcell}\row}{\*\abiendtable}\par
\pard\plain\ltrpar\ql\itap0\par

The known good RTF contained something like this:

{\s28\f0\fs24\lang1033{\*\listtag0}\par}}

So I just added two }} to the end of the corrupted RTF and I could open
it and reedit again.

** Affects: abiword (Ubuntu)
     Importance: Untriaged
         Status: Unconfirmed

-- 
Abiword occasionally corrupts RTF documents
https://launchpad.net/bugs/49993




More information about the desktop-bugs mailing list