[Bug 48614] New unneeded dependencies on hal

Akkana Peck akkzilla at shallowsky.com
Tue Jun 6 04:07:41 UTC 2006

Public bug reported:

Binary package hint: hal

I just attempted to update dapper -- my last update was a few days
before the official release -- and suddenly there are all sorts of
dependencies on hal that weren't there a week before dapper's release.
In particular, konqueror (via kdebase-kio-plugins), gnome-session (via
gnome-power-manager) and libgnomevfs2-common (via pmount) all have
broken dependencies without hal.

I uninstalled hal because it polls my disk several times a second, eats
cpu and causes one of my systems to make a faint beep several times per
second (bug 27323). Konqueror and gnome-session have been working fine
without it for at least the past six months, until just now. Was this an
intentional policy change? It seems like a significant change to make so
close within a few weeks of dapper's final release (and it makes these
packages unusable for me and anyone else who doesn't want the frequent

Please make hal optional, as it always used to be, at least until the
polling problem is fixed or a workaround is found. Thanks!

** Affects: hal (Ubuntu)
       Severity: Normal
       Priority: (none set)
         Status: Unconfirmed

New unneeded dependencies on hal

More information about the desktop-bugs mailing list