[Bug 74699] update-schemas: Error writing file "/var/lib/gconf/defaults/%gconf-tree.xml.new": File exists

Sam Hathaway ubuntu.com at munkynet.org
Wed Dec 6 20:37:38 UTC 2006

Public bug reported:

Binary package hint: gconf2

This is a problem in Edgy, as upgraded from Dapper. I did not see it in

A long time ago, during the installation of some package that uses
gconf, the configuration phase of the installation failed with the
following error:

Failed to write "/var/lib/gconf/defaults/%gconf-tree.xml": Error writing
file "/var/lib/gconf/defaults/%gconf-tree.xml.new": File exists

I forget which package originally triggered the error, I just started
noticing it during upgrades at some point.

Since then, every package that uses gconf (and tries to install a
schema) fails to configure with that same error. Investigating, I found
no evidence of a %gconf-tree.xml.new file. I tried all sorts of things,
including starting from an empty %gconf-tree.xml file and manually
installing all the schemas. Nothing worked, so I put the /var/lib/gconf
directory back the way I found it.

I have another similarly-configured Edgy box that was also upgraded from
Dapper that does not exhibit this problem. I installed all the same
gconf-using packages on that box, and then copied the entire
/var/lib/gconf directory from the working box to the broken box. No

In desperation, I reinstalled the system -- this time, a clean Edgy
install. I didn't reformat the hard drive, but I moved everything out of
the way and then directed the installer to use the existing filesystem.
After this, packages that wanted to install gconf schemas worked fine --

I upgraded evince from 0.6.1-0ubuntu1.1 to 0.6.1-0ubuntu1.2 today, and
during the configuration phase, I got the same error! Re-configuriung
(with dpkg --configure --pending) doesn't help, and again there's no
%gconf-tree.xml.new file in /var/lib/gconf.

The line in evince.postinst that triggers the bug is:

gconf-schemas --register evince-thumbnailer-djvu.schemas evince-thumbnai
ler-dvi.schemas evince-thumbnailer.schemas evince.schemas 

This is a fairly disruptive bug for some packages, since they can't
install their gconf schemas at all, and any configuration that happens
after gconf-schemas is called doesn't happen.

** Affects: gconf2 (Ubuntu)
     Importance: Undecided
         Status: Unconfirmed

update-schemas: Error writing file "/var/lib/gconf/defaults/%gconf-tree.xml.new": File exists

More information about the desktop-bugs mailing list