[Bug 74271] hald uses all of the cpu

Lars Pohlmann lars.pohlmann at googlemail.com
Mon Dec 4 10:21:11 GMT 2006


Public bug reported:

(using ubuntu-feisty).

on one (sony vaio pcg-fx-501) of my two laptops (same feisty on both) hald uses more than 40% of cpu all the time.
preventing the fan to stop and making the system slow. the other laptop doesn't have these symptoms.

in the laptop there are two pcmcia-cards (wlan and pcmcia-to-usb2 [with
one external harddrive attached to it]).

edit: this problem remains, when i boot the laptop without the pcmcia-
cards attached.

I don't know how to debug problems like these, so please tell me the
information you need (and how to get them, maybe).

Top (it looks like this all the time, even shortly after reboot, having
done nothing before...):

top - 18:29:47 up  1:14,  2 users,  load average: 2.22, 2.34, 2.38
Tasks: 108 total,   4 running, 104 sleeping,   0 stopped,   0 zombie
Cpu(s): 71.3%us, 25.4%sy,  0.2%ni,  2.1%id,  0.6%wa,  0.2%hi,  0.2%si,  0.0%st
Mem:    515880k total,   332264k used,   183616k free,    17784k buffers
Swap:  1212408k total,        0k used,  1212408k free,   200892k cached

  PID USER      PR  NI  VIRT  RES  SHR S %CPU %MEM    TIME+  COMMAND                                                                                                                                              
 4502 haldaemo  15   0 10640 9072 1724 R 41.5  1.8  32:20.73 hald                                                                                                                                                 
 2414 root      21  -4  2780 1176  396 S  5.7  0.2   3:15.74 udevd                                                                                                                                                
 4435 root      15   0  1712  652  544 S  1.9  0.1   0:26.34 syslogd                                                                                                                                              
 7281 lars      15   0 18768 5312 4140 S  1.9  1.0   1:01.74 gnome-volume-ma                                                                                                                                      
 7364 lars      15   0  8416 3456 2864 S  1.9  0.7   0:53.82 gnome-vfs-daemo                                                                                                                                      
 8083 lars      15   0 19628 8676 7376 S  1.9  1.7   0:38.19 battstat-applet                                                                                                                                      
    1 root      15   0  1692  540  456 S  0.0  0.1   0:01.83 init                                                                                                                                                 
    2 root      34  19     0    0    0 S  0.0  0.0   0:00.00 ksoftirqd/0   

p.s.: it's not a duplicate of this bug:
https://launchpad.net/distros/ubuntu/+source/gnome-vfs2/+bug/54684

i installed the provided packages and nothing changed.

** Affects: hal (Ubuntu)
     Importance: Undecided
         Status: Unconfirmed

-- 
hald uses all of the cpu
https://launchpad.net/bugs/74271



More information about the desktop-bugs mailing list