[Bug 54841] Re: rhythmbox crashes

Russel Winder russel at russel.org.uk
Wed Aug 2 09:06:32 BST 2006


Rhythmbox used to work for me on my workstation but now does not.  I
cannot remember when the change happened but I assume it was the Breezy
Badger -> Dapper Drake change.

Whenever I run rhythmbox, it starts, the frame comes up, I can play
music but the loading continues, it seems forever -- actually it seems
to finish and then restart as though in an infinite loop of some sort.
Well until the segfault.  I ran it under gdb and got:

gdb>bt
#0  0xb7c02803 in gst_push_src_get_type () from /usr/lib/libgstbase-0.10.so.0
#1  0xb7bb482f in gst_type_find_peek () from /usr/lib/libgstreamer-0.10.so.0
#2  0xb521e32a in mpeg_ts_probe_headers () from /usr/lib/gstreamer-0.10/libgsttypefindfunctions.so
#3  0xb7bb4c63 in gst_type_find_factory_call_function () from /usr/lib/libgstreamer-0.10.so.0
#4  0xb7c02c6b in gst_type_find_helper_get_range () from /usr/lib/libgstbase-0.10.so.0
#5  0xb521471b in gst_id3demux_get_type () from /usr/lib/gstreamer-0.10/libgstid3demux.so
#6  0xb7b9bad3 in gst_pad_set_active () from /usr/lib/libgstreamer-0.10.so.0
#7  0xb7b8a343 in gst_element_lost_state () from /usr/lib/libgstreamer-0.10.so.0
#8  0xb7b94db4 in gst_iterator_fold () from /usr/lib/libgstreamer-0.10.so.0
#9  0xb7b8a3e4 in gst_element_lost_state () from /usr/lib/libgstreamer-0.10.so.0
#10 0xb7b8a57b in gst_element_lost_state () from /usr/lib/libgstreamer-0.10.so.0
#11 0xb7b8a8ba in gst_element_lost_state () from /usr/lib/libgstreamer-0.10.so.0
#12 0xb5214cf0 in gst_id3demux_get_type () from /usr/lib/gstreamer-0.10/libgstid3demux.so
#13 0xb7b899a8 in gst_element_continue_state () from /usr/lib/libgstreamer-0.10.so.0
#14 0xb7b89fcd in gst_element_lost_state () from /usr/lib/libgstreamer-0.10.so.0
#15 0xb7b88ccc in gst_element_set_state () from /usr/lib/libgstreamer-0.10.so.0
#16 0xb524dfd9 in ?? () from /usr/lib/gstreamer-0.10/libgstdecodebin.so
#17 0x08292e78 in ?? ()
#18 0x00000003 in ?? ()
#19 0xb524cecf in ?? () from /usr/lib/gstreamer-0.10/libgstdecodebin.so
#20 0x086c43d0 in ?? ()
#21 0x00000000 in ?? ()
gdb>

It is perhaps worth noting that rhythmbox works fine on my laptop which
has the same OS so I am guessing it must be a hardware related issue or
an NFS related issue -- my workstation gets the files over NFS the
laptop does not.

-- 
rhythmbox crashes when loading my Music Library
https://launchpad.net/bugs/54841



More information about the desktop-bugs mailing list