[Bug 16639] New: Gstreamer apps don't report useful error messages

bugzilla-daemon at bugzilla.ubuntu.com bugzilla-daemon at bugzilla.ubuntu.com
Thu Sep 29 16:33:40 UTC 2005


Please do not reply to this email.  You can add comments at
http://bugzilla.ubuntu.com/show_bug.cgi?id=16639
Ubuntu | gstreamer0.8

           Summary: Gstreamer apps don't report useful error messages
           Product: Ubuntu
           Version: unspecified
          Platform: All
        OS/Version: Linux
            Status: UNCONFIRMED
          Severity: normal
          Priority: P2
         Component: gstreamer0.8
        AssignedTo: seb128 at ubuntu.com
        ReportedBy: psusi at cfl.rr.com
         QAContact: desktop-bugs at lists.ubuntu.com


It turned out that the reason I wasn't getting sound on my ubuntu desktop was
because I forgot to add my user account to the audio group, so I didn't have
permission to open the sound device.  

Gstreamer based apps did not give ANY kind of error message that might have
pointed me towards figuring that out.  The volume control simply said that there
were no detected sound cards.  Then sound configure applet simply said it failed
to build and output stream when I selected ALSA as the output and clicked on the
test button.  

It would have been infinitely more helpfull if some kind of error message was
presented that might have made me think that somewhere along the line, there was
an EPERM involved.

-- 
Configure bugmail: http://bugzilla.ubuntu.com/userprefs.cgi?tab=email
------- You are receiving this mail because: -------
You are the QA contact for the bug, or are watching the QA contact.




More information about the desktop-bugs mailing list