[Bug 16351] USB memory stick takes very long to automount

bugzilla-daemon at bugzilla.ubuntu.com bugzilla-daemon at bugzilla.ubuntu.com
Tue Sep 27 10:02:45 UTC 2005


Please do not reply to this email.  You can add comments at
http://bugzilla.ubuntu.com/show_bug.cgi?id=16351
Ubuntu | gnome-volume-manager


martin.pitt at ubuntu.com changed:

           What    |Removed                     |Added
----------------------------------------------------------------------------
            Summary|USB memory stick SanDisk    |USB memory stick takes very
                   |will not automount          |long to automount




------- Additional Comments From martin.pitt at ubuntu.com  2005-09-27 11:02 UTC -------
(In reply to comment #6)

> I followed the debugging steps from the website that you kindly provided. All
> the files have been attached (is there another way to do "attach multiple files
> at once" in the bugzilla system? This seems like a lot of waste of screen space :)

No, you can only attach one file at a time.

> Then I went ahead and placed USB stick into the USB port... this is when things
> went a little different than I would expect!
> After waiting for about 1 min. watching the console and more messages that
> showed up, the actual USB stick mounted quite nicely! Nautilus opened as one
> would expect and I was able to browse the pen drive with no problem (no manual
> mounting... it JUST WORKED).

Hmm, since it worked, the logs only show successful actions, so I can't see any
error in them. So it just takes very long until the device is mounted?

It would be interesting to see which component actually causes the lag. Can you
please do another experiment? Copy the following command into a terminal (but do
not press Enter yet):

  while true; do date; ls -l /dev/sda1 2>/dev/null; lshal 2>/dev/null |grep
/dev/sda1; sleep 1; done

Then insert your memory stick and at the same time press enter to start the
check. At first you will see only dates, and as soon as the device becomes
available and hal sees it, you should see more entries:

Di Sep 27 11:59:00 CEST 2005
[...]
Di Sep 27 11:59:05 CEST 2005
brw-r-----  1 root plugdev 8, 1 2005-09-27 11:59 /dev/sda1
Di Sep 27 11:59:06 CEST 2005
brw-r-----  1 root plugdev 8, 1 2005-09-27 11:59 /dev/sda1
  block.device = '/dev/sda1'  (string)

That would mean it took 5 seconds until /dev/sda1 appeared (i. e. the time the
kernel and hotplug need to see the device) and another second until hal sees it.
As soon as you see both lines (the two last ones), you can stop recording. What
are your results? (Just copy the whole output here if you are unsure)

-- 
Configure bugmail: http://bugzilla.ubuntu.com/userprefs.cgi?tab=email
------- You are receiving this mail because: -------
You are the QA contact for the bug, or are watching the QA contact.




More information about the desktop-bugs mailing list