[Bug 15780] When Print-server not found on network, cups-manager crashes

bugzilla-daemon at bugzilla.ubuntu.com bugzilla-daemon at bugzilla.ubuntu.com
Fri Sep 23 13:41:27 UTC 2005

Please do not reply to this email.  You can add comments at
Ubuntu | gnome-cups-manager

------- Additional Comments From steinar79 at gmail.com  2005-09-23 14:41 UTC -------
(In reply to comment #1)
> (In reply to comment #0)
> > I configured my network with shared printing. I found out that I had not opened
> > the right ports on my print server, but the real problem was that cups-manager
> > hanged 
> This is really a problem of how TCP is designed. If you completely block packets
> to the right port, your computer will not get any ICMP message that the port is
> invalid, and thus will get the usual 30 second timeout. Does it recover after 30
> seconds?
> > and even crashed Firefox when I tried to print a page
> That's more serious. That means you tried to print something in Firefox?
Thank you very much for the reply.

Here is a Scenario I did, hopefully to make it clearer.:
1. I followed the guide http://occy.net/printing. Configured the
/etc/cups/cupsd.conf on the server and /etc/cups/client.conf on the client as
described in the guide.
2. Blocked port 631 on print server
3. Started 'gnome-cups-manager' from terminal, and intended to test for about 15
	Result: - Network card increases activity a little bit and continues
		  After 7-8 minutes an error message appeared: 
		  ** (gnome-cups-manager:25187): WARNING **: IPP request failed with status 1280
		  ** (gnome-cups-manager:25187): WARNING **: IPP request failed with status 1280
4. I started firefox, then chose file - printer. It hangs, hand I have to quit
firefox with "killall firefox-bin". That did not happend with OpenOffice.org 2
beta 2, when I chose "file - print" from the menus.

Last time I tested gnome-cups-manager I tested for about 5 minutes, then no
error message appeared. Should not the error message appear a little earlier
than 7-8 minutes? And should not I be able to start gnome-cups-manager even if
it cannot find the network printer? What if I move the PC somwhere else and
intend to use another printer, cups-manager will not even start then without
configuring client.conf, I guess. Anyway Firefox hangs/crashes, I don't know if
this is a firefox issue, or a firefox/gnome-cups issue. 

5. I open port 631 on the print server:
	Result: I am able to open gnome-cups-manager and firefox does not crash when I
chose "file -print".

Configure bugmail: http://bugzilla.ubuntu.com/userprefs.cgi?tab=email
------- You are receiving this mail because: -------
You are the QA contact for the bug, or are watching the QA contact.

More information about the desktop-bugs mailing list