[Bug 15766] New: [breezy] evolution new message count on frequently lags

bugzilla-daemon at bugzilla.ubuntu.com bugzilla-daemon at bugzilla.ubuntu.com
Mon Sep 19 02:28:31 UTC 2005

Please do not reply to this email.  You can add comments at
Ubuntu | evolution

           Summary: [breezy] evolution new message count on frequently lags
           Product: Ubuntu
           Version: unspecified
          Platform: Other
               URL: http://bugzilla.gnome.org/show_bug.cgi?id=313712
        OS/Version: other
            Status: UNCONFIRMED
          Severity: normal
          Priority: P2
         Component: evolution
        AssignedTo: seb128 at ubuntu.com
        ReportedBy: desrt at desrt.ca
         QAContact: desktop-bugs at lists.ubuntu.com

since some time ago (am now running 2.4.0) there seems to have been a rework in
the imap code.  mostly this is visible in the fact that on startup evo used to
block for a second or two while it read all of my imap folder statuses and then
displayed them all at once.

in the current version, it displays all of the folders first and you can see
them updating as it queries the server.  this is 'imap', not 'imap4rev1'.

since the time of this change, the new mail count has been incorrect in certain
situations (as if it's not being properly updated).


1) go into evo to see 2 new messages in your inbox
2) erase one of them.  new message count falls to 1.
3) quit evo quickly  (like, press delete then ctrl+w in fairly rapid succession)
4) start evo again and notice that new message count is now 2 again.
5) switch to another folder and back to inbox, still 2.
6) click 'send/receive' and it drops to 1.

it doesn't happen all the time and it's fairly hard to characterise what makes
it happen and what doesn't but some things seem to make it work.  for example,
it doesn't seem to happen if i quit via the window manager close button (have to
use ctrl+w).  it also doesn't seem to happen if you wait around inside evo and
do some stuff after deleting the message before closing.

the other strange thing is, even though the new message count on the folder says 2

  #  Inbox (2)

the new message count at the top correctly says 1:

[ INBOX          117 total, 1 unread ]

anyway... i hope i've provided enough info that you can reproduce it for yourself.

btw: imap server is dovecot 0.99.11.  using it over ssh.


Configure bugmail: http://bugzilla.ubuntu.com/userprefs.cgi?tab=email
------- You are receiving this mail because: -------
You are the QA contact for the bug, or are watching the QA contact.

More information about the desktop-bugs mailing list