[Bug 12685] New: gnome-panel 2.11.5-0ubuntu1 doesn't build

bugzilla-daemon at bugzilla.ubuntu.com bugzilla-daemon at bugzilla.ubuntu.com
Thu Jul 14 15:31:45 UTC 2005


Please do not reply to this email.  You can add comments at
http://bugzilla.ubuntu.com/show_bug.cgi?id=12685
Ubuntu | gnome-panel

           Summary: gnome-panel 2.11.5-0ubuntu1 doesn't build
           Product: Ubuntu
           Version: unspecified
          Platform: Other
        OS/Version: other
            Status: UNCONFIRMED
          Severity: normal
          Priority: P2
         Component: gnome-panel
        AssignedTo: seb128 at ubuntu.com
        ReportedBy: cjwatson at ubuntu.com
         QAContact: desktop-bugs at lists.ubuntu.com


cc -shared  .libs/panel-applet.o .libs/panel-applet-gconf.o
.libs/panel-applet-shell.o .libs/panel-applet-marshal.o
.libs/panel-applet-enums.o .libs/GNOME_Panel-stubs.o .libs/GNOME_Panel-skels.o
.libs/GNOME_Pan
el-common.o  -L/usr/lib -L/usr/X11R6/lib /usr/lib/libgnomeui-2.so -lSM -lICE
/usr/lib/libglade-2.0.so /usr/lib/libbonoboui-2.so /usr/lib/libxml2.so -lpthread
-lz /usr/lib/libgnomecanvas-2.so /usr/lib/libgnome-2
.so /usr/lib/libpopt.so /usr/lib/libart_lgpl_2.so /usr/lib/libpangoft2-1.0.so
/usr/lib/libgtk-x11-2.0.so /usr/lib/libgdk-x11-2.0.so /usr/lib/libatk-1.0.so
/usr/lib/libgdk_pixbuf-2.0.so /usr/lib/libpangoxft-1.0.
so /usr/lib/libpangox-1.0.so /usr/lib/libpango-1.0.so /usr/lib/libgobject-2.0.so
/usr/lib/libgnomevfs-2.so /usr/lib/libbonobo-2.so /usr/lib/libgconf-2.so
/usr/lib/libbonobo-activation.so /usr/lib/libORBit-2.so
-lm /usr/lib/libgmodule-2.0.so -ldl /usr/lib/libgthread-2.0.so
/usr/lib/libglib-2.0.so  -Wl,-z -Wl,defs -Wl,-O1 -Wl,--as-needed
-Wl,--export-dynamic -pthread -Wl,-soname -Wl,libpanel-applet-2.so.0 -o .libs/libp
anel-applet-2.so.0.1.7
.libs/panel-applet.o: In function `panel_applet_request_focus':
/build/buildd/gnome-panel-2.11.5/./libpanel-applet/panel-applet.c:395: undefined
reference to `XQueryTree'

Restoring the -lX11 hack in libpanel-applet/Makefile.in is enough to fix the
problem. For good measure, perhaps you could fix it in
libpanel-applet/Makefile.am too and run automake-1.8?

-- 
Configure bugmail: http://bugzilla.ubuntu.com/userprefs.cgi?tab=email
------- You are receiving this mail because: -------
You are the QA contact for the bug, or are watching the QA contact.




More information about the desktop-bugs mailing list