[Bug 20429] New: gconf2 2.12.1 not working (dapper)

bugzilla-daemon at bugzilla.ubuntu.com bugzilla-daemon at bugzilla.ubuntu.com
Sat Dec 3 21:01:16 UTC 2005

Please do not reply to this email.  You can add comments at
Ubuntu | gconf2

           Summary: gconf2 2.12.1 not working (dapper)
           Product: Ubuntu
           Version: unspecified
          Platform: Other
               URL: http://ubuntuforums.org/showthread.php?t=96112
        OS/Version: other
            Status: UNCONFIRMED
          Severity: normal
          Priority: P2
         Component: gconf2
        AssignedTo: seb128 at ubuntu.com
        ReportedBy: mm-bugs at manno.name
         QAContact: desktop-bugs at lists.ubuntu.com


I have the same problem as discussed in

After login into gnome, i get an alert about gconfd not running and most of my
settings are gone.
I checked the output of 'ps jaxwww | grep gconf' and there is a running gconf
The problem persists with a fresh user account.
Downgrading gconf didn't help, but i haven't tried downgrading and replacing
$HOME/.gconf with an old backup yet.

'gconftool-2 -p && echo running' shows the server is reachable.

'/usr/lib/libgconf2-4/gconf-sanity-check-2 && echo ok' exits fine, too.

'gconftool-2 --get /schemas/apps/metacity/general/num_workspaces' shows there
are no schemas loaded.

I ran some tests from the gconf2 source and i'm unsure about the results.
'gdb ./gconf2-2.12.1/tests/.libs/lt-testgconf' segfaults, same test from gconf
2.12.0 worked.
 0xb7fcd55d in gconf_unescape_key (escaped_key=0x80623a8
    len=0x30) at gconf.c:2761
 2761              if (*p == '@')

I would be gratefull for any help on how to solve this...

Configure bugmail: http://bugzilla.ubuntu.com/userprefs.cgi?tab=email
------- You are receiving this mail because: -------
You are the QA contact for the bug, or are watching the QA contact.

More information about the desktop-bugs mailing list