[Bug 12870] removeable drives are not mounted at startup

bugzilla-daemon at bugzilla.ubuntu.com bugzilla-daemon at bugzilla.ubuntu.com
Tue Aug 23 14:29:46 UTC 2005


Please do not reply to this email.  You can add comments at
http://bugzilla.ubuntu.com/show_bug.cgi?id=12870
Ubuntu | gnome-volume-manager


martin.pitt at ubuntu.com changed:

           What    |Removed                     |Added
----------------------------------------------------------------------------
             Status|UNCONFIRMED                 |ASSIGNED
     Ever Confirmed|0                           |1
            Summary|Unable to manually mount /  |removeable drives are not
                   |unmount USB disks           |mounted at startup




------- Additional Comments From martin.pitt at ubuntu.com  2005-08-23 15:29 UTC -------
(In reply to comment #4)
> With the new udev version, I get different results with my 2 USB media:
>  - with my USB key, I can now unmount it without getting the error message, but
> it's still not auto-mounted if plugged before GNOME starts

That bug is probably still present, I will look at it soon.

>, and it still can't be mounted after being un-mounted.

This is fixed in:

 gnome-vfs2 (2.11.90-0ubuntu3) breezy; urgency=low
 .
   * Remove debian/patches/15_always_eject.patch:
     - This hack was replaced by a policy FDI in hal.
   * Add debian/patches/20_hal_eject.patch:
     - Properly initialize GnomeVFSDrive's must_eject_at_unmount field with
       libhal_drive_requires_eject().
   * debian/rules: Configure with --with-hal-mount=/usr/bin/pmount and
     --with-hal-umount=/usr/bin/pumount to make remounting work again.
     (part of #12870)

>  - with my USB hard drive, it doesn't appear when plugged. However, an entry in
> /dev is created and I can mount it using pmount /dev/sda1. 

Ok, that's the issue from above (not automounted at session start)

> Then, an icon appears
> in the mount applet and the computer place. Clicking on it from the mount applet
> crashes it, 

Will try to reproduce this.

> but clicking on it from Nautilus works well. Then, if I try to
> unmount it (from Nautilus), I get an error message (eject: impossible to open
> the file '/dev/sda1'), but it's successfully unmounted.

That's #5049. It works fine on amd64, but I think it happens on i386.

So the original bug title is solved now, I devote this bug to the other issues
here. However, I don't think that drives should actually be automounted at
startup; clicking on the icons should work probably, but mounting everything
"just for the case" is too much and often unnecessary. I'll look into it.

-- 
Configure bugmail: http://bugzilla.ubuntu.com/userprefs.cgi?tab=email
------- You are receiving this mail because: -------
You are the QA contact for the bug, or are watching the QA contact.




More information about the desktop-bugs mailing list