[ubuntu/dapper-security] vlc_0.8.4.debian-1ubuntu6.3_hppa_translations.tar.gz, vlc, vlc_0.8.4.debian-1ubuntu6.3_i386_translations.tar.gz, vlc_0.8.4.debian-1ubuntu6.3_amd64_translations.tar.gz, vlc_0.8.4.debian-1ubuntu6.3_powerpc_translations.tar.gz, vlc_0.8.4.debian-1ubuntu6.3_ia64_translations.tar.gz, vlc_0.8.4.debian-1ubuntu6.3_sparc_translations.tar.gz 0.8.4.debian-1ubuntu6.3 (Accepted)

Ubuntu Installer archive at ubuntu.com
Tue Sep 30 16:56:09 BST 2008


vlc (0.8.4.debian-1ubuntu6.3) dapper-security; urgency=low

  * SECURITY UPDATE: (LP: #207284)
   + debian/patches/031_CVE-2008-1489.dpatch
    - Integer overflow in the MP4_ReadBox_rdrf function in libmp4.c allows
      remote attackers to cause a denial of service (crash) and possibly
      execute arbitrary code via a crafted MP4 RDRF box that triggers a
      heap-based buffer overflow.

  * References
   + http://www.cve.mitre.org/cgi-bin/cvename.cgi?name=2008-1489
   + http://trac.videolan.org/vlc/changeset/09572892df7e72c0d4e598c0b5e076cf330d8b0a

Date: Tue, 01 Apr 2008 03:48:00 +0200
Changed-By: Emanuele Gentili <emgent at emanuele-gentili.com>
Maintainer: Sam Hocevar (Debian packages) <sam+deb at zoy.org>
https://launchpad.net/ubuntu/dapper/+source/vlc/0.8.4.debian-1ubuntu6.3
-------------- next part --------------
Format: 1.7
Date: Tue, 01 Apr 2008 03:48:00 +0200
Source: vlc
Binary: gnome-vlc gvlc kvlc libvlc0-dev mozilla-plugin-vlc qvlc vlc vlc-plugin-alsa vlc-plugin-arts vlc-plugin-esd vlc-plugin-ggi vlc-plugin-glide vlc-plugin-sdl vlc-plugin-svgalib wxvlc
Architecture: amd64_translations amd64 hppa_translations hppa i386_translations i386 ia64_translations ia64 powerpc_translations powerpc source sparc_translations sparc
Version: 0.8.4.debian-1ubuntu6.3
Distribution: dapper-security
Urgency: low
Maintainer: Sam Hocevar (Debian packages) <sam+deb at zoy.org>
Changed-By: Emanuele Gentili <emgent at emanuele-gentili.com>
Description:
 gnome-vlc  - GNOME frontend for VLC (dummy legacy package)
 gvlc       - GTK+ frontend for VLC (dummy legacy package)
 kvlc       - KDE frontend for VLC (dummy legacy package)
 libvlc0-dev - development files for VLC
 mozilla-plugin-vlc - multimedia plugin for Mozilla based on VLC
 qvlc       - Qt frontend for VLC (dummy legacy package)
 vlc        - multimedia player for all audio and video formats
 vlc-plugin-alsa - ALSA audio output plugin for VLC
 vlc-plugin-arts - aRts audio output plugin for VLC
 vlc-plugin-esd - Esound audio output plugin for VLC
 vlc-plugin-ggi - GGI video output plugin for VLC
 vlc-plugin-sdl - SDL video and audio output plugin for VLC
 wxvlc      - wxWidgets frontend for VLC
 vlc-plugin-glide - Glide video output plugin for VLC
 vlc-plugin-svgalib - SVGAlib video output plugin for VLC
Changes:
 vlc (0.8.4.debian-1ubuntu6.3) dapper-security; urgency=low
 .
   * SECURITY UPDATE: (LP: #207284)
    + debian/patches/031_CVE-2008-1489.dpatch
     - Integer overflow in the MP4_ReadBox_rdrf function in libmp4.c allows
       remote attackers to cause a denial of service (crash) and possibly
       execute arbitrary code via a crafted MP4 RDRF box that triggers a
       heap-based buffer overflow.
 .
   * References
    + http://www.cve.mitre.org/cgi-bin/cvename.cgi?name=2008-1489
    + http://trac.videolan.org/vlc/changeset/09572892df7e72c0d4e598c0b5e076cf330d8b0a
Files:
 c7d14a8ed59cd8c96e6a1f70b6ab4ba9 7788368 graphics optional vlc_0.8.4.debian-1ubuntu6.3_amd64.deb
 e0987ba4a9f90cb0eec046715a0f9758 905684 libdevel optional libvlc0-dev_0.8.4.debian-1ubuntu6.3_amd64.deb
 df2a06fdbe6eb13a81fa4363435b89f9 1234 oldlibs optional gnome-vlc_0.8.4.debian-1ubuntu6.3_amd64.deb
 bcdfda47866de3f97f703fbfb186d13f 1236 oldlibs optional gvlc_0.8.4.debian-1ubuntu6.3_amd64.deb
 ef99d08f6077dcdc0b4edc4a7ba9fda6 4164 graphics optional vlc-plugin-esd_0.8.4.debian-1ubuntu6.3_amd64.deb
 f7fc4239fdcf60c711c99f839d26599e 10318 graphics optional vlc-plugin-alsa_0.8.4.debian-1ubuntu6.3_amd64.deb
 6911e06b2b1582c9adb0a37a6524031f 10242 graphics optional vlc-plugin-sdl_0.8.4.debian-1ubuntu6.3_amd64.deb
 23955b112e4f9eee7b2bd13413ae0d22 5778 graphics optional vlc-plugin-ggi_0.8.4.debian-1ubuntu6.3_amd64.deb
 aae5aa24b470a235da22faa237c6d39b 954 oldlibs optional qvlc_0.8.4.debian-1ubuntu6.3_amd64.deb
 e69ffdbd9655f5f4ad85a6019cd02bef 3872 graphics optional vlc-plugin-arts_0.8.4.debian-1ubuntu6.3_amd64.deb
 60d4c2a3192b877f960e7cfff0820223 701638 graphics optional mozilla-plugin-vlc_0.8.4.debian-1ubuntu6.3_amd64.deb
 f589aa0e259361325b4a6e7c77cd6363 970 oldlibs optional kvlc_0.8.4.debian-1ubuntu6.3_amd64.deb
 3fe13b95b76d9797e63ecbc8930a3fd1 388882 graphics optional wxvlc_0.8.4.debian-1ubuntu6.3_amd64.deb
 6e775d21803079978fc73eab71a6da1b 2706893 raw-translations - vlc_0.8.4.debian-1ubuntu6.3_amd64_translations.tar.gz
 3782dcbeca6e29d265d506521284c3ff 8370752 graphics optional vlc_0.8.4.debian-1ubuntu6.3_hppa.deb
 3f167bf9521018478df899e31f71da89 1054798 libdevel optional libvlc0-dev_0.8.4.debian-1ubuntu6.3_hppa.deb
 61617d164f28e6994eb8b14bd31fa6c2 1234 oldlibs optional gnome-vlc_0.8.4.debian-1ubuntu6.3_hppa.deb
 b92fe9c45ce54aac0eceb18f1cd622e1 1238 oldlibs optional gvlc_0.8.4.debian-1ubuntu6.3_hppa.deb
 d963b550802a47a157f82d39a927a1f0 6670 graphics optional vlc-plugin-esd_0.8.4.debian-1ubuntu6.3_hppa.deb
 f6d137ff668024d9bb80362e96f538fb 13204 graphics optional vlc-plugin-alsa_0.8.4.debian-1ubuntu6.3_hppa.deb
 d532627acd97a4237d91370e5637b15e 12402 graphics optional vlc-plugin-sdl_0.8.4.debian-1ubuntu6.3_hppa.deb
 debc8beec1f40480bffa817b964ecd62 7262 graphics optional vlc-plugin-ggi_0.8.4.debian-1ubuntu6.3_hppa.deb
 f22392565c17cfaa9acb40407ab350f1 960 oldlibs optional qvlc_0.8.4.debian-1ubuntu6.3_hppa.deb
 6cc19e7984fe45abe860509f93cb6253 5112 graphics optional vlc-plugin-arts_0.8.4.debian-1ubuntu6.3_hppa.deb
 fa846a738cc31622b0f4fbf795a91a6a 774368 graphics optional mozilla-plugin-vlc_0.8.4.debian-1ubuntu6.3_hppa.deb
 1209eb2ecaebbcd793e2c24f0bcaa9db 968 oldlibs optional kvlc_0.8.4.debian-1ubuntu6.3_hppa.deb
 3376615a055808d0df9fdc8d43c72a62 438854 graphics optional wxvlc_0.8.4.debian-1ubuntu6.3_hppa.deb
 a48e6423ab3f889f00a0c6e1bd0c291a 2706915 raw-translations - vlc_0.8.4.debian-1ubuntu6.3_hppa_translations.tar.gz
 50b13814d30a2a12ec2dc413975aab89 7805538 graphics optional vlc_0.8.4.debian-1ubuntu6.3_i386.deb
 1ac8588977bf2fdf6eef107ae7214a88 890958 libdevel optional libvlc0-dev_0.8.4.debian-1ubuntu6.3_i386.deb
 b985d0489f5d614525692d61b7776f46 1230 oldlibs optional gnome-vlc_0.8.4.debian-1ubuntu6.3_i386.deb
 a78768c20b9f022f6fa341b225316925 1238 oldlibs optional gvlc_0.8.4.debian-1ubuntu6.3_i386.deb
 737c38d716b5b8ba2bf60d2a26bdf1cf 4334 graphics optional vlc-plugin-esd_0.8.4.debian-1ubuntu6.3_i386.deb
 c26f6e8b46accd970ec18a50725d4cdd 10126 graphics optional vlc-plugin-alsa_0.8.4.debian-1ubuntu6.3_i386.deb
 93a1e12340dab88c3129d54dfd1d7e72 9550 graphics optional vlc-plugin-sdl_0.8.4.debian-1ubuntu6.3_i386.deb
 5bdb60515c140738f6dbf9e20245a77e 5464 graphics optional vlc-plugin-ggi_0.8.4.debian-1ubuntu6.3_i386.deb
 92c1c4f06244e43852c6429832978900 3880 graphics optional vlc-plugin-glide_0.8.4.debian-1ubuntu6.3_i386.deb
 ec04271204cc260a6a4b22625b7539e7 952 oldlibs optional qvlc_0.8.4.debian-1ubuntu6.3_i386.deb
 09770652944357b2f4062ef6e9a3f001 3656 graphics optional vlc-plugin-arts_0.8.4.debian-1ubuntu6.3_i386.deb
 54c9ba1b95ede91b282630dbb381db0c 697216 graphics optional mozilla-plugin-vlc_0.8.4.debian-1ubuntu6.3_i386.deb
 fb3435c90d08bc7b3d066e0da18066ac 970 oldlibs optional kvlc_0.8.4.debian-1ubuntu6.3_i386.deb
 d7596a4fbf8803e38adb38ddf00917c5 4164 graphics optional vlc-plugin-svgalib_0.8.4.debian-1ubuntu6.3_i386.deb
 1e9a82e322341551ce5b17cf544f5a06 367590 graphics optional wxvlc_0.8.4.debian-1ubuntu6.3_i386.deb
 244ee008d548f57f4c129fad9cb22498 2706886 raw-translations - vlc_0.8.4.debian-1ubuntu6.3_i386_translations.tar.gz
 92e0da188ed881c542e80e6803d944e6 9849942 graphics optional vlc_0.8.4.debian-1ubuntu6.3_ia64.deb
 cb4f670ca61d2dc25272ed589092b91b 1380410 libdevel optional libvlc0-dev_0.8.4.debian-1ubuntu6.3_ia64.deb
 56f1759aed649c91d8b8f8c32762954a 1228 oldlibs optional gnome-vlc_0.8.4.debian-1ubuntu6.3_ia64.deb
 7901ade2cfc57d76419029a95fc12be2 1238 oldlibs optional gvlc_0.8.4.debian-1ubuntu6.3_ia64.deb
 08de983b7d37e0ea6acb25f94476bd38 5710 graphics optional vlc-plugin-esd_0.8.4.debian-1ubuntu6.3_ia64.deb
 b57be036d2b6e7d648b73763a39882e7 14574 graphics optional vlc-plugin-alsa_0.8.4.debian-1ubuntu6.3_ia64.deb
 9d961a1bb026e97ad489b5e114ed3ac2 14762 graphics optional vlc-plugin-sdl_0.8.4.debian-1ubuntu6.3_ia64.deb
 e03b8cff05a78fc4cacbcbdacd0b6992 8302 graphics optional vlc-plugin-ggi_0.8.4.debian-1ubuntu6.3_ia64.deb
 92e2c9c1eb3c5afccfbff7cb5d8c7ab7 954 oldlibs optional qvlc_0.8.4.debian-1ubuntu6.3_ia64.deb
 b2e141a2822781415f117f96752de732 5106 graphics optional vlc-plugin-arts_0.8.4.debian-1ubuntu6.3_ia64.deb
 3fd8cb00f60d7a3f914d87666b9de8f7 1017588 graphics optional mozilla-plugin-vlc_0.8.4.debian-1ubuntu6.3_ia64.deb
 57ffd1a64310c1b07ccd0e2474b4bded 972 oldlibs optional kvlc_0.8.4.debian-1ubuntu6.3_ia64.deb
 c58126b0dc84406a5246e4543d04cb06 474120 graphics optional wxvlc_0.8.4.debian-1ubuntu6.3_ia64.deb
 df34ba5c12428ac8f533e161be0faa22 2706903 raw-translations - vlc_0.8.4.debian-1ubuntu6.3_ia64_translations.tar.gz
 fd5edabb4c41167cbe3cb3ee588da746 7949900 graphics optional vlc_0.8.4.debian-1ubuntu6.3_powerpc.deb
 a93d9bf4534e591fdfef589f9c41335e 915202 libdevel optional libvlc0-dev_0.8.4.debian-1ubuntu6.3_powerpc.deb
 ef6c6bbcd4cb547589f466ae1e16737f 1234 oldlibs optional gnome-vlc_0.8.4.debian-1ubuntu6.3_powerpc.deb
 824add72bd829718efa4caa25cfca7ba 1238 oldlibs optional gvlc_0.8.4.debian-1ubuntu6.3_powerpc.deb
 6de1d9b79d61755ec484e0fc05913b25 6606 graphics optional vlc-plugin-esd_0.8.4.debian-1ubuntu6.3_powerpc.deb
 788298e7dc371b991381f9492a85aa60 12308 graphics optional vlc-plugin-alsa_0.8.4.debian-1ubuntu6.3_powerpc.deb
 012161b051876958aec94a8f8b405cef 12438 graphics optional vlc-plugin-sdl_0.8.4.debian-1ubuntu6.3_powerpc.deb
 2364c4a9fda8f4da6bbbcbb3b0def3b1 7216 graphics optional vlc-plugin-ggi_0.8.4.debian-1ubuntu6.3_powerpc.deb
 cfd04199908ba6fdcf8d3547d2433157 962 oldlibs optional qvlc_0.8.4.debian-1ubuntu6.3_powerpc.deb
 9c06e5e8432f5593ced622f6b13cf0e0 5384 graphics optional vlc-plugin-arts_0.8.4.debian-1ubuntu6.3_powerpc.deb
 0415648de24359b7a4770e696cc47291 706066 graphics optional mozilla-plugin-vlc_0.8.4.debian-1ubuntu6.3_powerpc.deb
 580759e1f4cb38d481edcd0201af1faa 976 oldlibs optional kvlc_0.8.4.debian-1ubuntu6.3_powerpc.deb
 19bfe5fe4aa5dcad406ec17db10a338c 357806 graphics optional wxvlc_0.8.4.debian-1ubuntu6.3_powerpc.deb
 7ef7322cf8385bc59fe28f02ecd0f5c8 2706863 raw-translations - vlc_0.8.4.debian-1ubuntu6.3_powerpc_translations.tar.gz
 81f1b366d45cf6f4aaac577aab2acf00 1949 graphics optional vlc_0.8.4.debian-1ubuntu6.3.dsc
 3de8aa43b82c7ff635e5ba4711b129cf 576041 graphics optional vlc_0.8.4.debian-1ubuntu6.3.diff.gz
 677a43743d4a8218249f8bc89080a635 7625970 graphics optional vlc_0.8.4.debian-1ubuntu6.3_sparc.deb
 ec8885bac24a9024afe7e6a9901a3e17 898602 libdevel optional libvlc0-dev_0.8.4.debian-1ubuntu6.3_sparc.deb
 b87d28d4d30c30dcc46edf9d2675eb78 1228 oldlibs optional gnome-vlc_0.8.4.debian-1ubuntu6.3_sparc.deb
 e17b9ef2fb377e9cc7888632ac3b78cf 1234 oldlibs optional gvlc_0.8.4.debian-1ubuntu6.3_sparc.deb
 d6f03a92aad08db0890a7fab35f7f195 4456 graphics optional vlc-plugin-esd_0.8.4.debian-1ubuntu6.3_sparc.deb
 2ed1b0d565380cd4f943896df2d9997e 10318 graphics optional vlc-plugin-alsa_0.8.4.debian-1ubuntu6.3_sparc.deb
 9a6372c7b200854fb7aaa484b93847c1 9620 graphics optional vlc-plugin-sdl_0.8.4.debian-1ubuntu6.3_sparc.deb
 a848da4bbd85b7029684d5b9bae7c630 5482 graphics optional vlc-plugin-ggi_0.8.4.debian-1ubuntu6.3_sparc.deb
 98937bf58801cc6e35c100594283f5ee 954 oldlibs optional qvlc_0.8.4.debian-1ubuntu6.3_sparc.deb
 88d324db5726bec9bae285251416566d 3664 graphics optional vlc-plugin-arts_0.8.4.debian-1ubuntu6.3_sparc.deb
 f131948e329c11695b76dc1fdabb45c6 691106 graphics optional mozilla-plugin-vlc_0.8.4.debian-1ubuntu6.3_sparc.deb
 cf2cdc49e37a0d82173abcb2921a6551 970 oldlibs optional kvlc_0.8.4.debian-1ubuntu6.3_sparc.deb
 ce386132a7f0cbefcdbcd1f87e9c3fae 366372 graphics optional wxvlc_0.8.4.debian-1ubuntu6.3_sparc.deb
 11495faec27c3181d9949163df026c64 2706919 raw-translations - vlc_0.8.4.debian-1ubuntu6.3_sparc_translations.tar.gz


More information about the dapper-changes mailing list