Accepted wpasupplicant 0.4.8-1build1 (source)

Reinhard Tartler siretart at
Fri Mar 31 21:50:05 BST 2006

 OK: wpasupplicant_0.4.8-1build1.dsc
     -> Component: main Section: net
 OK: wpasupplicant_0.4.8-1build1.diff.gz

Hash: SHA1

Format: 1.7
Date: Fri, 31 Mar 2006 15:41:26 +0200
Source: wpasupplicant
Binary: wpagui wpasupplicant
Architecture: source
Version: 0.4.8-1build1
Distribution: dapper
Urgency: low
Maintainer: Debian/Ubuntu wpasupplicant Maintainers <pkg-wpa-devel at>
Changed-By: Reinhard Tartler <siretart at>
 wpagui     - GUI for wpa_supplicant
 wpasupplicant - Client support for WPA and WPA2 (IEEE 802.11i)
Closes: 356072 356842 357760 358137 358138 359814
 wpasupplicant (0.4.8-1build1) dapper; urgency=low
   * fakesync from debian.
 wpasupplicant (0.4.8-1) unstable; urgency=low
   [ Reinhard Tartler ]
   * Finally bringing in the new Upstream version with the ap scan patch for
     wpa-cli, required by network-manager (Closes: #356072)
   * Dropping Mode 3 (start by init script) (Closes: #356842, #357760)
   * add hint for associating to hidden ssids (Closes: #358137)
   * add a note for faciliating debugging connection problems
   * add this note to README.modes as well.
   * remove or backup obsolete conffiles
   * install the wpasupplicant.conf(5) manpage (Closes: #358138)
   * don't start wpa_supplicant for loopback interface (Closes: #359814)
   * add explanation about action scripts, mentioning that we expect now
     the action script to create a file indicating that the interface is ready
     for use.
   * add warning in NEWS.Debian that upgrading to this package requires
     manual intervention by the local admin.
   * move old 'default configuration' to /usr/share/doc/wpasupplicant/examples
     as example for connecting to open APs.
   * remove version restriction from preinst. This means that obsoleted
     conffiles are always removed!
   * moved the ifupdown script to /etc/wpa_supplicant/
   * added note about binaries beeing moved to /sbin
   [ Scott James Remnant ]
   * Undo 0.4.8-0ubuntu2's replacement of the preinst/postinst/postrm triad,
     which replaced the upgrade-failure proof and policy compliant code with
     "something else".
   * Restore change to ifupdown script that makes "wpa-conf" unnecessary.
   * Move /etc/wpa_supplicant.conf to /etc/wpa_supplicant/wpa_supplicant.conf
     if the user has modified it, otherwise remove it and install the new file.
   * Remove 0_ from if-*.d symlink names as we don't force an order or
     even serialisation.
   [ Kel Modderman ]
   * Remove check for /proc/net/packet. (Closes: M#37121)
   * Add timeout loop when launching a wpa_cli action script in conjunction
     with the manual inet METHOD, to allow other ifupdown hooks to
     post-configure the interface just as they would have if using a standard
     method such as dhcp or static. Introduce WPA_CLI_ACTFILE to allow a
     wpa_cli action script to signal connected state to ifupdown.
   * Add skeleton wpa_cli action script to examples.
   * Simplify wpasupplicant.examples.
   * Don't install wpa_supplcant.defconf as the default wpa_supplicant conffile,
     our users don't want that file interrogated by anyone, even dpkg.
 3d0d0850cbc28e03f62d5c23f59f3d76 856 net optional wpasupplicant_0.4.8-1build1.dsc
 282ea88f8d59b6b0f25910ae0f2dff36 39025 net optional wpasupplicant_0.4.8-1build1.diff.gz

Version: GnuPG v1.4.2.2 (GNU/Linux)
Comment: Debian Powered!


More information about the dapper-changes mailing list