Accepted amule 2.1.3-1~dapper1 (source)

Ubuntu Installer archive at
Fri Dec 1 14:46:31 GMT 2006

 OK: amule_2.1.3-1~dapper1.dsc
     -> Component: universe Section: x11
 OK: amule_2.1.3.orig.tar.gz
 OK: amule_2.1.3-1~dapper1.diff.gz

Format: 1.7
Date: Fri,  1 Dec 2006 14:35:30 +0000
Source: amule
Binary: amule amule-daemon amule-common amule-utils amule-utils-gui
Architecture: source
Version: 2.1.3-1~dapper1
Distribution: dapper-backports
Urgency: low
Maintainer: Julien Delange <julien at>
Changed-By: John Dong <john.dong at>
 amule      - client for the eD2k and Kad networks, like eMule
 amule-common - common files for the rest of aMule packages
 amule-daemon - non-graphic version of aMule, a client for the eD2k and Kad netwo
 amule-utils - utilities for aMule (command-line version)
 amule-utils-gui - graphic utilities for aMule
Closes: 300414 330705 340395 346581 346581 347783 348579 348752 358968 359093 360135 360138 361770 362725 366777 368381 368447 369746 369775 369796 369800 369959 369995 370068 370421 372279 374806 377760 377761
 amule (2.1.3-1~dapper1) dapper-backports; urgency=low
   * Automated backport upload; no source changes.
 amule (2.1.3-1) unstable; urgency=low
   * The "Over my dead body you'll wear those sneakers to college!" release.
   * New upstream release packaged.
   * Ship an amulegui.desktop file in /usr/share/applications.
   * Fix typos in manpages, spotted by A. Costa.  (Closes: #377760, 377761)
   * Now that xmule has been removed from the archive (#370524), get rid of
     diversions in the package completely:
     + make amule-utils conflict with xmule (<= 1.10.0b-1).
     + loose ed2k.wrapper, and don't have /usr/bin/ed2k be a link to it, but
       the real ed2k binary.
     If xmule ever comes back, this will be handled with alternatives instead.
   * Introduce code in amule-utils.preinst to clean up all the diversion mess
     that previous versions left behind. Kudos to Steinar H. Gunderson for the
     detailed analysis of the situation.  (Closes: #372279, #374806)
 amule (2.1.2-3) unstable; urgency=low
   * The "Look at you now, young man" release.
   * Move /usr/share/amule/webserver from amule-daemon to amule-common:
     + introduce the appropriate Replaces.
     + lower dependency on amule-common by amule-utils and amule-utils-gui
       to a recommends, and move the tiny /usr/share/cas from amule-common
       to amule-utils because of this.
   * Sundry fixes to debian/control:
     + don't make amule recommend amule-daemon, only amule-utils, and make it
       suggest amule-utils-gui; make amule-daemon suggest amule-utils as well.
     + don't make amule-common conflict amule-utils, only replace it as adviced
       by Steve Langasek and myself in #343909 five months ago.
     + rewrite all package descriptions, trying to follow the guidelines in
       Dev-Ref. amule-common no longer claims to include the ed2k link handler,
       which closes: #370421.
   * New patches (handled with quilt, so modified debian/rules to invoke it,
     and added it to Build-Depends):
     + debian/patches/cas_configfile.c_good_default_paths.diff:
       Make /usr/bin/cas write proper paths for stat.png and tmp.html to the
       configfile it creates when one is not present, and make it use Bitstream
       Vera by default (ttf-bitstream-vera added to Recommends).
     + debian/patches/configure_ignore_gdlib-config_garbage.diff:
       Reintroduce patch by Steve Langasek to ignore the output of gdlib-config,
       as to avoid linking against unneeded libraries. The patch was introduced
       in amule 2.0.3-4 and dropped in 2.1.0-1 (?!).  (Closes: #340395)
   * The build system detects the presence of bfd.h from binutils-dev and
     unconditionally links against, introducing a dependency against
     binutils in the packages. To fix this without the need of Build-Conflicts,
     build the package with `$(MAKE) BFD_LIB= BFD_FLAGS=` from debian/rules.
   * Fix the dpkg-divert mess that happened with the move of ed2k out of the
     amule package (binary was in amule-utils, but dpkg-divert was still called
     with --package amule); see amule-utils.preinst. The plan is to get rid of
     dpkg-divert as soon as I get something done about xmule (see #370524).
   * Make the changes to amule.xpm that make it 32x32 as per the Menu Policy
     keep the aspect ratio instead of just resizing. Also, ship the new icon in
     debian/amule-32.xpm and replace it at runtime, instead of shipping changes
     (which are three times bigger) in the .diff.gz.
   * Drop not-really-useful README.Debian for amule-utils and amule, and write
     basic instructions to run amuled in amule-daemon.README.Debian.
   * Revamp the copyright file, with proper list of authors, copyright notices,
     and license terms (GPLv2 or higher, not only v2).
   * Add a X-VCS-Bzr header to the source package, pointing to the repository
     where the packaging is kept.
 amule (2.1.2-2) unstable; urgency=low
   * The "Oooh, poor kiddo" release.
   * Overhaul debian/rules. Among other changes:
     + provide a binary-arch target that actually builds some .debs; this fixes
       recent FTBFS in buildds.  (Closes: #369995)
     + do not call ./configure more times than needed. (Closes: #368381)
     + remove dpatch, since it is no longer used; drop build-dependency, and
       delete no longer used patches from the patches/ subdirectory as well.
     + build-depend on autotools-dev, to ensure that the config.{sub,guess}
       snippet actually makes us build against the latest version of these files.
     + use debhelper *.install files instead of mv commands from debian/rules;
       while at it, remove *.dirs files, since they're not needed.
     + use $builddir != $srcdir, to make the clean rule simpler.
   * Add to amule-utils missing Replaces: amule (<< 2.1.2-1) (closes: #370068).
     In amule 2.1.1-3, debian/rules called dh_link without -pamule-common, thus
     shipping the symlinks in amule instead of amule-common.
   * Do not ship the placeholder manpages from the debian/mans directory, and
     ship the ones provided by upstream, which have actual content, are useful
     and translated to four languages.
   * Add missing dpkg-divert --remove /usr/share/man/man1/ed2k.1.gz in
     amule-utils.postrm. Will hopefully get totally rid of dpkg-divert in the
     next upload.
   * Remove debian/amule.postinst and debian/amule-utils-gui.postinst, since
     they only contain the very same snippet dh_installmenu already installs.
   * Make point to wxcas.xpm and alc.xpm instead of using
     amule.xpm for all three shipped binaries, and ship a copy of amule.xpm as
     amulegui.xpm since amule-utils-gui does not depend on amule (thx, lintian).
   * Fix debian/watch file; now the shortcut is used.
   * Add myself as an uploader, and mutter something about #369995 traffic.
 amule (2.1.2-1.1) unstable; urgency=low
   * NMU to fix serious bug before dinstall, with maintainer's permission.
   * Make amule-utils Replace: amule-common (<< 2.1.2-1), since ed2k.amule
     and other files moved from there in the last upload. (Closes: #369959)
 amule (2.1.2-1) unstable; urgency=low
   * New upstream release, youhou !
   * Delete some dependencies on amule and amule-daemon (Closes: #369746)
   * Fix type in the init script of amuled (Closes: #368447)
   * Arch of amule-common is now all (Closes: #369796)
   * Remove old patches (Closes: #369775)
   * fix error in debian/rules file, can now build with -O2 (Closes: #369800)
   * Should not take 100% CPU (Closes: #361770)
   * Desktop file is present for amulegui (Closes: #366777)
 amule (2.1.1-3) unstable; urgency=low
   * Change description (Closes: #360138)
   * Can control file status with amulecmd (Closes: #360135)
   * Change amule-utils description (Closes: #362725)
 amule (2.1.1-2) unstable; urgency=low
   * Fix build-depends, add dpatch (Closes: #359093)
 amule (2.1.1-1) unstable; urgency=low
   * New upstream release (Closes: #358968)
   * Fix crypto++ identity bug ( Closes: #348579 )
   * ed2k links should work now (Closes: #300414)
 amule (2.1.0-3) unstable; urgency=low
   * Fix init.d mistake (Closes: #346581)
 amule (2.1.0-2) unstable; urgency=low
   * Fix typo in debian/control (Closes: #330705)
   * No dependency on amule for amule-utils-gui (Closes: #348752)
   * Add init-script for amule-daemon (Closes: #346581)
   * Support now .mka and .flac files (Closes: #347783)
 30014bb5ec7b9f86a37beee03805376a 625 x11 optional amule_2.1.3-1~dapper1.dsc
 cb433bee9e92dc57aae35de53031f8b4 4087524 x11 optional amule_2.1.3.orig.tar.gz
 5db758ddda82fa0c62e195934a124b6d 18169 x11 optional amule_2.1.3-1~dapper1.diff.gz

More information about the dapper-changes mailing list