[ubuntu/cosmic-updates] gpac 0.5.2-426-gc5ad4e4+dfsg5-4ubuntu0.1 (Accepted)

Ubuntu Archive Robot cjwatson+ubuntu-archive-robot at chiark.greenend.org.uk
Thu Mar 28 15:58:08 UTC 2019


gpac (0.5.2-426-gc5ad4e4+dfsg5-4ubuntu0.1) cosmic-security; urgency=medium

  * SECURITY UPDATE: Fix multiple buffer overflow issues
    - debian/patches/CVE-2018-7752-CVE-2018-1000100.patch: fix buffer overflow
      in the gf_media_avc_read_sps
    - debian/patches/CVE-2018-13005-CVE-2018-13006.patch: fixed 2 possible
      heap overflows
    - debian/patches/CVE-2018-20760.patch: check error code on call to
      gf_utf8_wcstombs
    - debian/patches/CVE-2018-20761-CVE-2018-20762.patch: fix some overflows
      due to strcpy
    - debian/patches/CVE-2018-20763.patch: add some boundary checks on
      gf_text_get_utf8_line
    - CVE-2018-7752
    - CVE-2018-13005
    - CVE-2018-13006
    - CVE-2018-20760
    - CVE-2018-20761
    - CVE-2018-20762
    - CVE-2018-20763
    - CVE-2018-1000100

Date: 2019-03-27 19:00:26.340377+00:00
Changed-By: Paulo Flabiano Smorigo <pfsmorigo at canonical.com>
Signed-By: Ubuntu Archive Robot <cjwatson+ubuntu-archive-robot at chiark.greenend.org.uk>
https://launchpad.net/ubuntu/+source/gpac/0.5.2-426-gc5ad4e4+dfsg5-4ubuntu0.1
-------------- next part --------------
Sorry, changesfile not available.


More information about the Cosmic-changes mailing list