[ubuntu-cloud-archive/havana-proposed] pytest (Accepted)

Scott Moser smoser at ubuntu.com
Fri Sep 6 17:46:18 UTC 2013


 pytest (2.3.5-1svn1~cloud0) precise-havana; urgency=low
 .
   * New package for the Ubuntu Cloud Archive to support testing of
     msgpack-python.
 .
 pytest (2.3.5-1svn1) saucy; urgency=low
 .
   Upload current Debian packaging svn head to fix autopkgtest.
 .
   * debian/tests/control: Drop trailing comma from test dependencies, which
     causes autopkgtest to fail.
 .
 pytest (2.3.5-1) unstable; urgency=low
 .
   [ Jakub Wilk ]
   * Use canonical URIs for Vcs-* fields.
 .
   [ Simon Chopin ]
   * New upstream version (Closes: #707151)
   * B-D on debhelper 8.1 to conform to Policy 3.9.4
   * Add DEP-8 tests (Closes: #702121)
   * Patch the tests to restore the permissions of the tmpdir used in tests
 .
   [ Sebastian Ramacher ]
   * Upload to unstable.
 .
 pytest (2.3.4-1~exp2) experimental; urgency=low
 .
   * Fix the version detection regexp to be less inclusive (Closes: #703351)
   * Adjust the shebang replacement regexp in postinst and rtinstall.
     Thanks to Roderich Schupp.
   * Remove the doc build directory in the clean target (Closes: #702117)
 .
 pytest (2.3.4-1~exp1) experimental; urgency=low
 .
   * Upload new upstream release to experimental (Closes: #699312)
     + Update the patch paths to build only the English documentation
   * Fix the permissions for the py.test-3 executable.
   * Up the dependency on python-py to 1.4.11
   * Add python(3)-nose, python-pexpect, python(3)-mock (>= 1.0.1)
     and python-twisted-core as Build-Depends to skip less tests.
   * Suggests python-mock (>= 1.0.1) in python-pytest
   * Bump Standards-Version to 3.9.4, no change needed.
   * Update copyright year.
 .
 pytest (2.2.4-2) unstable; urgency=low
 .
   * Use rt{install, remove} mechanisms from the Python package to replace the
     wrapper system. /usr/bin/py.test-X.Y will now be available only if the
     corresponding python package is installed. Thanks to Jakub Wilk.
 .
 pytest (2.2.4-1) unstable; urgency=low
 .
   * New upstream release
   * Drop patch fix-grammar-manpage (included upstream)
   * Bump the dependency to python[3]-py to >= 1.4.8
 .
 pytest (2.2.3-3) unstable; urgency=low
 .
   * Fix the version detection in the wrapper (Closes: #668691)
 .
 pytest (2.2.3-2) unstable; urgency=low
 .
   * Fix the shell wrapper (Closes: #668519)
   * Use the wrapper for py.test and py3-test to simplify d/rules
   * Enable test suite
     + Uncomment the override_dh_auto_test target
   * Build-Conflicts on old versions of python-pytest-xdist (<< 1.5)
 .
 pytest (2.2.3-1) unstable; urgency=low
 .
   * Initial release (Closes: #664071)
   * Disable the test suite for the bootstrap.

Date: Fri, 30 Aug 2013 14:07:22 +0100
Changed-By: James Page <james.page at ubuntu.com>
Signed-By: James Page <james.page at ubuntu.com> 
Published-By: Scott Moser <smoser at ubuntu.com>



More information about the Cloud-archive-changes mailing list