Updated certification-docs package not appearing on Launchpad

Daniel Manrique daniel.manrique at canonical.com
Thu Dec 17 18:49:03 UTC 2015

Launchpad should always send the email, even if to say it rejected the
package because of $REASONS.

At this point it looks like something is wrong with Launchpad. It may
make sense to ask in #launchpad (I think it's on freenode?). I was
about to go in and do it for you but I'd just be a middleman, so I
suggest you ask there directly.

On Thu, Dec 17, 2015 at 1:25 PM, Roderick W. Smith
<rod.smith at canonical.com> wrote:
> Hash: SHA1
> On 12/17/2015 11:43 AM, Daniel Manrique wrote:
>> This is weird. Can you try creating a PPA under your user
>> (https://launchpad.net/~/+activate-ppa) and uploading the package
>> there?
> Done, and no luck:
> https://launchpad.net/~rodsmith/+archive/ubuntu/testing
> I tried doing this both from my laptop (which I use for official
> Canonical projects) and my desktop (which I use for my rEFInd project,
> among other things). I'm getting no e-mail saying anything about the
> files being accepted or rejected. Aside from the complaint if I try
> uploading again, it's as if I never uploaded anything.
> I also tried uploading an interim copy of rEFInd to my testing PPA,
> and it was accepted, although the web UI says that the build is
> scheduled for an hour from now. The fact that rEFInd was accepted
> would tend to rule out the OpenStack outage as being a cause. At this
> point I'm guessing there's something subtly wrong with the packaging,
> but lintian isn't complaining, and I'm able to build a package locally
> just fine.
>> On Thu, Dec 17, 2015 at 11:27 AM, Roderick W. Smith
>> <rod.smith at canonical.com> wrote: Daniel e-mailed me directly and
>> suggested I update the package version and resubmit, so I've done
>> that, but it's still not working....
>> On 12/17/2015 11:24 AM, Daniel Manrique wrote:
>>>>> Hey... I still don't see it :(
>>>>> Could you show me the output of the dput command you're
>>>>> using? (if you can --debug it, all the better).
>>>>> It really should appear by now.
>> Sure, here's the dput output on my end:
>> $ dput ppa:hardware-certification/public
>> ../certification-docs_0.1.4.1-0ppa1_source.changes Checking
>> signature on .changes gpg: Signature made Thu 17 Dec 2015 11:16:51
>> AM EST using RSA key ID 95D058E6 gpg: Good signature from "Roderick
>> W. Smith <rod.smith at canonical.com>" Good signature on
>> ../certification-docs_0.1.4.1-0ppa1_source.changes. Checking
>> signature on .dsc gpg: Signature made Thu 17 Dec 2015 11:16:51 AM
>> EST using RSA key ID 95D058E6 gpg: Good signature from "Roderick W.
>> Smith <rod.smith at canonical.com>" Good signature on
>> ../certification-docs_0.1.4.1-0ppa1.dsc. Package includes an
>> .orig.tar.gz file although the debian revision suggests that it
>> might not be required. Multiple uploads of the .orig.tar.gz may be
>> rejected by the upload queue management software. Uploading to ppa
>> (via ftp to ppa.launchpad.net): Uploading
>> certification-docs_0.1.4.1-0ppa1.dsc: done. Uploading
>> certification-docs_0.1.4.1.orig.tar.gz: done. Uploading
>> certification-docs_0.1.4.1-0ppa1.debian.tar.gz: done. Uploading
>> certification-docs_0.1.4.1-0ppa1_source.changes: done. Successfully
>> uploaded packages.
>>>>> On Thu, Dec 17, 2015 at 11:18 AM, Roderick W. Smith
>>>>> <rod.smith at canonical.com> wrote: On 12/17/2015 10:37 AM,
>>>>> Daniel Manrique wrote:
>>>>>>>> The PPA still shows this version:
>>>>>>>> 0.1.3-0ppa1
>>>>>>>> looks like something went wrong with the build process
>>>>>>>> if it's not letting you upload, yet doesn't show the
>>>>>>>> new version.
>>>>>>>> Could you bump your package's version to 0.1.4-0ppa2
>>>>>>>> and reupload?
>>>>> I've just uploaded an updated version (
>>>>> There's no sign of it yet on the PPA's web page, but it's
>>>>> only been a minute or so.
>>>>>>>> Let me know so I can keep an eye on the PPA.
>>>>>>>> On Thu, Dec 17, 2015 at 10:06 AM, Roderick W. Smith
>>>>>>>> <rod.smith at canonical.com> wrote: Hi,
>>>>>>>> I recently made some changes to the certification-docs
>>>>>>>> package
>>>>>>>> (https://code.launchpad.net/certification-docs), which
>>>>>>>> I submitted to out PPA with:
>>>>>>>> dput ppa:hardware-certification/public
>>>>>>>> This submission seemed to be accepted; however, it's
>>>>>>>> not appeared in the PPA, and I can find no error
>>>>>>>> messages in my e-mail inbox or on the PPA's web
>>>>>>>> interface
>>>>>>>> (https://launchpad.net/~hardware-certification/+archive/ubuntu/p
> ublic)
> .
>>>>> I
>>>>>>>> can build it locally and get a valid .deb file.
>>>>>>>> Attempting to resubmit the package via dput results in
>>>>>>>> the error:
>>>>>>>> Package has already been uploaded to ppa on
>>>>>>>> ppa.launchpad.net Nothing more to do for
>>>>>>>> certification-docs_0.1.4-0ppa1_source.changes
>>>>>>>> I made my initial submission yesterday afternoon, so
>>>>>>>> there's been more than enough time for the build to
>>>>>>>> happen. Does anybody have any clues about what's
>>>>>>>> happening, or have suggestions for finding out what's
>>>>>>>> wrong? I've done this before, albeit not very often, so
>>>>>>>> I doubt if it's a permissions issue.
>>>>>>>> Thanks!
>>>>>>>>> -- Checkbox-devel mailing list
>>>>>>>>> Checkbox-devel at lists.ubuntu.com Modify settings or
>>>>>>>>> unsubscribe at:
>>>>>>>>> https://lists.ubuntu.com/mailman/listinfo/checkbox-devel
> - --
> Rod Smith
> Server and Cloud Certification Engineer
> rod.smith at canonical.com
> Version: GnuPG v2.0.22 (GNU/Linux)
> iQEcBAEBAgAGBQJWcv4HAAoJEFgyRI+V0Fjm7YwH/1dsBxMfegq3gY7tyrqBxZJK
> mmYSatXJCaFkQGv8dVTL1x7tbXaPl3oI1rHKzx3cLZTbYqsCrLXQ7WpJbh2C3ybh
> F9es6BlvdkYGQouW4s3GFDr9F2im5b4E4Uwskjp5liivnIBHt3oU1QRcYvCLRCQt
> iBJw0grPfJpvnsxMX8YYWc9V5YJOxmrA6rKQ2LmOJNvOT4H7K//W2OMokwq0y3ph
> DGx1ptEYGC7JNFchcYeOArMLLDv6nGrlcKar8Q7Mq9JPNc7zck45z97KhRpUf/0C
> AclkA+vQJ+MCxa4xbMdLk4IGiYZwIu7fy/ajQWU+xVK+BniEohiWdEv9NaAbXrc=
> =yXQq

More information about the Checkbox-devel mailing list