Accepted postgresql-7.4 1:7.4.8-5 (source)

Martin Pitt martin.pitt at ubuntu.com
Mon Jun 6 08:15:03 CDT 2005


-----BEGIN PGP SIGNED MESSAGE-----
Hash: SHA1

Origin: Debian/experimental
Format: 1.7
Date: Mon,  06 Jun 2005 14:03:25 +0100
Source: postgresql-7.4
Binary: postgresql-plpython-7.4, postgresql-doc-7.4, postgresql-client-7.4, postgresql-plperl-7.4, postgresql-pltcl-7.4, postgresql-server-dev-7.4, libpq3, postgresql-7.4, postgresql-contrib-7.4
Architecture: source
Version: 1:7.4.8-5
Distribution: breezy
Urgency: low
Maintainer: Martin Pitt <mpitt at debian.org>
Changed-By: Martin Pitt <martin.pitt at ubuntu.com>
Description: 
 postgresql-7.4 - object-relational SQL database, version 7.4 server
Closes: 308986
Changes: 
 postgresql-7.4 (1:7.4.8-5) experimental; urgency=low
 .
   * debian/postgresql-7.4.install: Install pg_encoding to enable encodings
     other than SQL_ASCII.
 .
 postgresql-7.4 (1:7.4.8-4) experimental; urgency=low
 .
   * Add CAN numbers to previous changelogs.
   * debian/patches/13_postgresql.conf.patch: Enable tcpip_socket by default.
 .
 postgresql-7.4 (1:7.4.8-3) experimental; urgency=low
 .
   * Skipping version 7.4.8-2 since this already exists in unstable from the
     legacy packages.
   * debian/rules: Fixed documentation path configure option. Closes: #308986
 .
 postgresql-7.4 (1:7.4.8-1) experimental; urgency=low
 .
   * New upstream version:
     - Prevent calling conversion functions by users. [CAN-2005-1409]
     - Prevent calling tsearch2 functions by users. [CAN-2005-1410]
     - Fix buffer overflows in the PL/PGSQL parser in gram.y. [CAN-2005-0247]
   * Removed patch debian/patches/50_CAN-2005-0247.patch (contained in new
     upstream version).
   * Added postgresql-server-dev-7.4 package.
 .
 postgresql-7.4 (1:7.4.7-5) experimental; urgency=low
 .
   * Ship reindexdb in -contrib.
   * Added debian/patches/14_pager.patch: Use /usr/bin/pager instead of more as
     default pager in psql. (Bug #304459)
   * Added debian/postgresql-doc-7.4.doc-base: Register doc package in
     doc-base.
 .
 postgresql-7.4 (1:7.4.7-4) experimental; urgency=low
 .
   * Do not install pg_config, client applications are supposed to use
     libpq-dev from 8.0.
   * debian/postgresql-7.4.init: Added autovacuum functions.
 .
 postgresql-7.4 (1:7.4.7-3) experimental; urgency=low
 .
   * Renamed packages pg-pl*-7.4 to postgresql-pl*-7.4 for consistency.
   * -contrib: Only recommend, not depend on libpg-perl and libdbd-pg-perl.
   * Added debian/patches/13_postgresql.conf.patch:
     - Patch for Debian changes to the default configuration.
     - Enable stats_row_level to allow pg_autovacuum to work.
 .
 postgresql-7.4 (1:7.4.7-2) experimental; urgency=low
 .
   * Corrected pg-pltcl-7.4 dependency from libtcl8.4 to tcl8.4
   * Now depend on postgresql-common >= 3 which provides more maintainer script
     functions.
   * Call new common maintainer script functions in postinst/postrm scripts.
   * Compress manpages.
 .
 postgresql-7.4 (1:7.4.7-1) experimental; urgency=low
 .
   * First release for the multiversion/multicluster architecture.
   * This version is not vulnerable to the following security vulnerabilities:
       . Load arbitrary shared libs, execute startup function [CAN-2005-0227]
       . Execute functions with aggregate wrapper [CAN-2005-0244]
       . Buffer overflow and 64-bit issues in contrib/intagg [CAN-2005-0246]
       . Insecure temporary files in make_oidjoins_check [CAN-2004-0977]
   * Introduced epoch "1" to force libpq3 from this new architecture to be
     always newer than the version from the legacy package.
Files: 
 50ee979019622f8852444cfd67b58e7e 9947820 misc optional postgresql-7.4_7.4.8.orig.tar.gz
 74eb60dcc627dc3ac7ab5af06db914c3 1018 misc optional postgresql-7.4_7.4.8-5.dsc
 97a4cdc4213a635a97c95e8133ddc999 20985 misc optional postgresql-7.4_7.4.8-5.diff.gz
-----BEGIN PGP SIGNATURE-----
Version: GnuPG v1.2.5 (GNU/Linux)

iQEVAwUBQqRJnQF4adwMEr3XAQIWfwf/XCigIno5fk496+1Prr/ra5pAvK3N16v7
7HxcDuJHAjHpdNNupU7gLOKybS5G8Uxq/9GwOxIBEidS2OylM7QVp2+dLlHjBCyG
El47KvqIl/fmQM8KhqOoYR7+2S62Q7gzV/UGw7C3mRcxvOhqOKdkiiQmlxP+wPTj
lIexr528RTqB9HH1Cjl+f6Gs2y6apJQVVpZrcpJDhiRGuhRx2IWZzwDiG9GZQwfj
/nw5GGhcuQPNJQrv1rYc1pGb6/C+rfso4Lr/yFEXD00Dmz0qyMgIfx1yK5ZfsT9o
ANCv7VYPpMenSRiFZd0SKM6Ban3rb+U2GfhS7z6EFlXbG150zF0iiA==
=pqT9
-----END PGP SIGNATURE-----


Accepted:
postgresql-7.4_7.4.8-5.diff.gz
  to pool/universe/p/postgresql-7.4/postgresql-7.4_7.4.8-5.diff.gz
postgresql-7.4_7.4.8-5.dsc
  to pool/universe/p/postgresql-7.4/postgresql-7.4_7.4.8-5.dsc
postgresql-7.4_7.4.8.orig.tar.gz
  to pool/universe/p/postgresql-7.4/postgresql-7.4_7.4.8.orig.tar.gz




More information about the breezy-changes mailing list