Accepted openssh 1:4.1p1-2ubuntu1 (source)

Colin Watson cjwatson at
Fri Jun 3 19:30:02 CDT 2005

Hash: SHA1

Format: 1.7
Date: Sat,  4 Jun 2005 01:16:24 +0100
Source: openssh
Binary: ssh-askpass-gnome openssh-client-udeb ssh openssh-server openssh-client openssh-server-udeb
Architecture: source
Version: 1:4.1p1-2ubuntu1
Distribution: breezy
Urgency: low
Maintainer: Matthew Vernon <matthew at>
Changed-By: Colin Watson <cjwatson at>
 openssh-client - Secure shell client, an rlogin/rsh/rcp replacement
 openssh-client-udeb - Secure shell client for the Debian installer
 openssh-server - Secure shell server, an rshd replacement
 openssh-server-udeb - Secure shell server for the Debian installer
 ssh        - Secure shell client and server (transitional package)
 ssh-askpass-gnome - under X, asks user for a passphrase for ssh-add
Closes: 87900 141979 147212 151321 192234 233012 247521 295757 308868
 openssh (1:4.1p1-2ubuntu1) breezy; urgency=low
   * Resynchronise with Debian.
 openssh (1:4.1p1-2) experimental; urgency=low
   * Drop debconf support for allowing SSH protocol 1, which is discouraged
     and has not been the default since openssh 1:3.0.1p1-1. Users who need
     this should edit sshd_config instead (closes: #147212).
   * Since ssh-keysign isn't used by default (you need to set
     EnableSSHKeysign to "yes" in /etc/ssh/ssh_config), having a debconf
     question to ask whether it should be setuid is overkill, and the
     question text had got out of date anyway. Remove this question, ship
     ssh-keysign setuid in openssh-client.deb, and set a statoverride if the
     debconf question was previously set to false.
   * Add lintian overrides for the above (setuid-binary,
   * Fix picky lintian errors about slogin symlinks.
   * Fix DEB_HOST_ARCH_OS/DEB_HOST_GNU_SYSTEM compatibility handling.
   * Apply Linux 2.2 workaround (see #239999) only on Linux.
 openssh (1:4.1p1-1) experimental; urgency=low
   * New upstream release.
     - Normalise socket addresses returned by get_remote_hostname(), fixing
       4-in-6 mapping issues with AllowUsers et al (closes: #192234).
   * Take upstream's hint and disable the unsupported USE_POSIX_THREADS
     (closes: #295757, #308868, and possibly others; may open other bugs).
     Use PAM password authentication to avoid #278394. In future I may
     provide two sets of binaries built with and without this option, since
     it seems I can't win.
   * Disable ChallengeResponseAuthentication in new installations, returning
     to PasswordAuthentication by default, since it now supports PAM and
     apparently works better with a non-threaded sshd (closes: #247521).
   * openssh-server Suggests: rssh (closes: #233012).
   * Change libexecdir to /usr/lib/openssh, and fix up various alternatives
     and configuration files to match (closes: #87900, #151321).
   * Fix up very old sshd_config files that refer to /usr/libexec/sftp-server
     (closes: #141979).
 e3c8cc31754aff674635c5fe485acb85 914 net standard openssh_4.1p1-2ubuntu1.dsc
 3709109adf0b82176668b3d3478dd033 909689 net standard openssh_4.1p1.orig.tar.gz
 c7dc5fe153c321f2af019817b95d4447 138774 net standard openssh_4.1p1-2ubuntu1.diff.gz

Version: GnuPG v1.4.1 (GNU/Linux)


  to pool/main/o/openssh/openssh_4.1p1-2ubuntu1.diff.gz
  to pool/main/o/openssh/openssh_4.1p1-2ubuntu1.dsc
  to pool/main/o/openssh/openssh_4.1p1.orig.tar.gz

More information about the breezy-changes mailing list