[ubuntu/bionic-proposed] linux-gke-5.4 5.4.0-1071.76~18.04.3 (Accepted)
Andy Whitcroft
apw at canonical.com
Fri May 13 08:07:00 UTC 2022
linux-gke-5.4 (5.4.0-1071.76~18.04.3) bionic; urgency=medium
* bionic/linux-gke-5.4: 5.4.0-1071.76~18.04.3 -proposed tracker (LP: #1971121)
* Miscellaneous Ubuntu changes
- [packaging] enable arm64
- [packaging] Ignore missing prior ABI
- [packaging] Build-dep on dwarves
[ Ubuntu: 5.4.0-1071.76 ]
* focal/linux-gke: 5.4.0-1071.76 -proposed tracker (LP: #1970823)
* Miscellaneous Ubuntu changes
- [packaging] Enable arm64 support
- [packaging] import arm64 configs from gcp
- [packaging] update/clean annotations after arm64
- [packaging] Add bootloader arch selectors
- [packaging] build-depend on dwarves
- [packaging] Ignore missing prior ABI
[ Ubuntu: 5.4.0-1070.73 ]
* Rebase on Ubuntu-gcp-5.4.0-1073.78
- updateconfigs after rebase on gcp
* arm64 support (LP: #1925421)
- SAUCE: perf/smmuv3: Allow sharing MMIO registers with the SMMU driver
- SAUCE: arm64: Split the old READ_IMPLIES_EXEC workaround from executable
- mm/memory-failure: Add memory_failure_queue_kick()
- ACPI: APEI: Kick the memory_failure() queue for synchronous errors
- perf: Add Arm CMN-600 PMU driver
- perf: Add Arm CMN-600 DT binding
- PCI/ACPI: Add Ampere Altra SOC MCFG quirk
- mm: memblock: replace dereferences of memblock_region.nid with API calls
- mm: make early_pfn_to_nid() and related defintions close to each other
- mm: remove CONFIG_HAVE_MEMBLOCK_NODE_MAP option
- mm: free_area_init: use maximal zone PFNs rather than zone sizes
- mm: use free_area_init() instead of free_area_init_nodes()
- alpha: simplify detection of memory zone boundaries
- arm: simplify detection of memory zone boundaries
- arm64: simplify detection of memory zone boundaries for UMA configs
- csky: simplify detection of memory zone boundaries
- m68k: mm: simplify detection of memory zone boundaries
- parisc: simplify detection of memory zone boundaries
- sparc32: simplify detection of memory zone boundaries
- unicore32: simplify detection of memory zone boundaries
- xtensa: simplify detection of memory zone boundaries
- mm: memmap_init: iterate over memblock regions rather that check each PFN
- mm/page_alloc.c: initialize memmap of unavailable memory directly
- mm: pass migratetype into memmap_init_zone() and move_pfn_range_to_zone()
- mm: rename memmap_init() and memmap_init_zone()
- mm: simplify parater of function memmap_init_zone()
- mm/page_alloc.c: refactor initialization of struct page for holes in memory
layout
- mm: remove early_pfn_in_nid() and CONFIG_NODES_SPAN_OTHER_NODES
- mm: free_area_init: allow defining max_zone_pfn in descending order
- arc: fix memory initialization for systems with two memory banks
- mm: rename free_area_init_node() to free_area_init_memoryless_node()
- mm: clean up free_area_init_node() and its helpers
- mm: simplify find_min_pfn_with_active_regions()
- docs/vm: update memory-models documentation
- SAUCE: hwmon: Add Ampere Altra HW monitor driver
- arm64: NUMA: Kconfig: Increase NODES_SHIFT to 4
- driver/perf: Add PMU driver for the ARM DMC-620 memory controller
- perf/arm_dmc620_pmu: Fix error return code in dmc620_pmu_device_probe()
- perf: arm_dsu: Support DSU ACPI devices
- SAUCE: perf: arm_dsu: Allow IRQ to be shared among devices.
- Perf: arm-cmn: Allow irq to be shared.
- perf: arm-cmn: Fix unsigned comparison to less than zero
- perf/arm-cmn: Fix PMU instance naming
- perf/arm-cmn: Move IRQs when migrating context
* Update gvnic driver code (LP: #1953575)
- netdev: pass the stuck queue to the timeout handler
- gve: Get and set Rx copybreak via ethtool
- gve: Add stats for gve.
- gve: Use dev_info/err instead of netif_info/err.
- gve: Add Gvnic stats AQ command and ethtool show/set-priv-flags.
- gve: NIC stats for report-stats and for ethtool
- gve: Batch AQ commands for creating and destroying queues.
- gve: Use link status register to report link status
- gve: Enable Link Speed Reporting in the driver.
- gve: Replace zero-length array with flexible-array member
- gve: Add support for raw addressing device option
- gve: Add support for raw addressing to the rx path
- gve: Rx Buffer Recycling
- net: gve: convert strlcpy to strscpy
- net: gve: remove duplicated allowed
- gve: Move some static functions to a common file
- gve: gve_rx_copy: Move padding to an argument
- gve: Make gve_rx_slot_page_info.page_offset an absolute offset
- SAUCE: Revert "gve: Check TX QPL was actually assigned"
- gve: Add support for raw addressing in the tx path
- gve: Introduce a new model for device options
- gve: Introduce per netdev `enum gve_queue_format`
- gve: adminq: DQO specific device descriptor logic
- gve: Add support for DQO RX PTYPE map
- gve: Add dqo descriptors
- gve: Add DQO fields for core data structures
- gve: Update adminq commands to support DQO queues
- gve: DQO: Add core netdev features
- gve: DQO: Add ring allocation and initialization
- gve: DQO: Configure interrupts on device up
- gve: DQO: Add TX path
- gve: DQO: Add RX path
- gve: Fix warnings reported for DQO patchset
- gve: DQO: Fix off by one in gve_rx_dqo()
- gve: Propagate error codes to caller
- gve: Simplify code and axe the use of a deprecated API
- gve: DQO: Remove incorrect prefetch
- gve: fix the wrong AdminQ buffer overflow check
- gve: DQO: avoid unused variable warnings
- gve: Check TX QPL was actually assigned
- gve: Avoid freeing NULL pointer
- gve: Properly handle errors in gve_assign_qpl
- gve: report 64bit tx_bytes counter from gve_handle_report_stats()
- gve: Switch to use napi_complete_done
- gve: Add rx buffer pagecnt bias
- gve: Do lazy cleanup in TX path
- gve: Recover from queue stall due to missed IRQ
- gve: Add netif_set_xps_queue call
- gve: Allow pageflips on larger pages
- gve: Track RX buffer allocation failures
- gve: Add RX context.
- gve: Implement packet continuation for RX.
- gve: Add a jumbo-frame device option.
- gve: Fix off by one in gve_tx_timeout()
- gve: fix unmatched u64_stats_update_end()
- gve: fix for null pointer dereference.
- gve: Correct order of processing device options
- gve: Add optional metadata descriptor type GVE_TXD_MTD
- gve: Move the irq db indexes out of the ntfy block struct
- gve: Update gve_free_queue_page_list signature
- gve: remove memory barrier around seqno
- gve: Implement suspend/resume/shutdown
- gve: Add consumed counts to ethtool stats
- gve: Add tx|rx-coalesce-usec for DQO
- gve: Use kvcalloc() instead of kvzalloc()
Date: 2022-05-08 06:48:10.509431+00:00
Changed-By: Khaled El Mously <khalid.elmously at canonical.com>
Signed-By: Andy Whitcroft <apw at canonical.com>
https://launchpad.net/ubuntu/+source/linux-gke-5.4/5.4.0-1071.76~18.04.3
-------------- next part --------------
Sorry, changesfile not available.
More information about the Bionic-changes
mailing list