[ubuntu/bionic-proposed] glib2.0 2.56.4-0ubuntu0.18.04.5 (Accepted)

Gunnar Hjalmarsson gunnarhj at ubuntu.com
Thu Nov 21 12:32:34 UTC 2019


glib2.0 (2.56.4-0ubuntu0.18.04.5) bionic; urgency=medium

  [ Gunnar Hjalmarsson ]
  * d/p/gcredentialsprivate-Document-the-various-private-macros.patch,
    d/p/credentials-Invalid-Linux-struct-ucred-means-no-informati.patch,
    d/p/GDBus-prefer-getsockopt-style-credentials-passing-APIs.patch:
    - Ensure libdbus clients can authenticate with a GDBusServer like
      the one in ibus. The patches cherry picked from 2.62.2-2 in focal
      in order to allow the ibus fix of CVE-2019-14822 to be re-enabled
      without breaking ibus for Qt applications (LP: #1844853).

  [ Iain Lane ]
  * d/p/Add-a-test-for-GDBusServer-authentication.patch: Additionally backport
    this commit to add a test for the above fixes.
    + BD on libdbus-1-dev so that the above test gets run properly.

Date: Thu, 31 Oct 2019 00:16:00 +0100
Changed-By: Gunnar Hjalmarsson <gunnarhj at ubuntu.com>
Maintainer: Ubuntu Developers <ubuntu-devel-discuss at lists.ubuntu.com>
Signed-By: Iain Lane <iain at orangesquash.org.uk>
https://launchpad.net/ubuntu/+source/glib2.0/2.56.4-0ubuntu0.18.04.5
-------------- next part --------------
Format: 1.8
Date: Thu, 31 Oct 2019 00:16:00 +0100
Source: glib2.0
Architecture: source
Version: 2.56.4-0ubuntu0.18.04.5
Distribution: bionic
Urgency: medium
Maintainer: Ubuntu Developers <ubuntu-devel-discuss at lists.ubuntu.com>
Changed-By: Gunnar Hjalmarsson <gunnarhj at ubuntu.com>
Launchpad-Bugs-Fixed: 1844853
Changes:
 glib2.0 (2.56.4-0ubuntu0.18.04.5) bionic; urgency=medium
 .
   [ Gunnar Hjalmarsson ]
   * d/p/gcredentialsprivate-Document-the-various-private-macros.patch,
     d/p/credentials-Invalid-Linux-struct-ucred-means-no-informati.patch,
     d/p/GDBus-prefer-getsockopt-style-credentials-passing-APIs.patch:
     - Ensure libdbus clients can authenticate with a GDBusServer like
       the one in ibus. The patches cherry picked from 2.62.2-2 in focal
       in order to allow the ibus fix of CVE-2019-14822 to be re-enabled
       without breaking ibus for Qt applications (LP: #1844853).
 .
   [ Iain Lane ]
   * d/p/Add-a-test-for-GDBusServer-authentication.patch: Additionally backport
     this commit to add a test for the above fixes.
     + BD on libdbus-1-dev so that the above test gets run properly.
Checksums-Sha1:
 ece41ba7002490f6dfa96efa3b9d2ec51c133521 3609 glib2.0_2.56.4-0ubuntu0.18.04.5.dsc
 3b99bf8bf7b9bdd9476a33389e2c9c0897f23c0b 89480 glib2.0_2.56.4-0ubuntu0.18.04.5.debian.tar.xz
 015dd96a160680ce4e64dce81ac0de528f5acc02 13619 glib2.0_2.56.4-0ubuntu0.18.04.5_source.buildinfo
Checksums-Sha256:
 ba900df93c508318994dbf74f183bd6ea55f985ae14e146f05f88b592d42e72d 3609 glib2.0_2.56.4-0ubuntu0.18.04.5.dsc
 8a265bdbd25d1d2dc1e4e45c6adf30446777c6e019d2057b5091d26633894962 89480 glib2.0_2.56.4-0ubuntu0.18.04.5.debian.tar.xz
 6cb58b3ecaea575146091274c3652fae154634eeda8e837ec6ddd8f124fb9c6b 13619 glib2.0_2.56.4-0ubuntu0.18.04.5_source.buildinfo
Files:
 11b6aa89c13a209e45605c287440a59e 3609 libs optional glib2.0_2.56.4-0ubuntu0.18.04.5.dsc
 56b913b00f3dd62f5b34618bd81df30e 89480 libs optional glib2.0_2.56.4-0ubuntu0.18.04.5.debian.tar.xz
 1d8a651b26c5bb3a1b3fb256fe0fa300 13619 libs optional glib2.0_2.56.4-0ubuntu0.18.04.5_source.buildinfo
Original-Maintainer: Debian GNOME Maintainers <pkg-gnome-maintainers at lists.alioth.debian.org>


More information about the Bionic-changes mailing list