bzr: ERROR: No module named expat; use SimpleXMLTreeBuilder instead

Martin Packman martin.packman at canonical.com
Fri Mar 23 10:32:57 UTC 2012


On 23/03/2012, Erik de Castro Lopo <mle+tools at mega-nerd.com> wrote:
> Hi all,
>
> I hadn't used bzr on my Debian test/unstable machine for a while
> but now I'm getting the following error:
>
>     $ bzr branch ~/Bzr/libsndfile-dev libsndfile-tmp
>     bzr: ERROR: No module named expat; use SimpleXMLTreeBuilder instead
>
>     You may need to install this Python library separately.

Make sure you have the package 'python' installed, not just
'python-minimal'. If you're still stuck after checking that, and
repairing the install if needed, do:

    $ python -c "import xml.parsers.expat"

If that also gives a traceback, paste it here along with your sys.path contents.

Martin



More information about the bazaar mailing list