bzr-svn: Issue pushing to svn repo with hooks.

Eric Berry elberry at
Mon Feb 13 20:20:51 UTC 2012

I recently upgraded Bazaar on my Mac and got the latest bzr-svn, and now
I'm getting some error messages I was previously getting.

It has been a very long time since I upgraded, so I don't know what the
last version of bzr-svn was where it worked.

The issue is that our SVN repo has some commit hooks which reject the
commit and return a message with a code-review number in it - or a message
when the corresponding Jira ticket isn't in the right place.

Previously, when the hook rejected the commit bzr-svn would printout
whatever error message there was. After upgrading I now get an error

bzr: ERROR: exceptions.AssertionError: adding busy connection in

Traceback (most recent call last):
  File "/Library/Python/2.6/site-packages/bzrlib/", line 946, in
    return the_callable(*args, **kwargs)
  File "/Library/Python/2.6/site-packages/bzrlib/", line 1150,
in run_bzr
    ret = run(*run_argv)
  File "/Library/Python/2.6/site-packages/bzrlib/", line 699, in
  File "/Library/Python/2.6/site-packages/bzrlib/", line 721, in
    return self._operation.run_simple(*args, **kwargs)
  File "/Library/Python/2.6/site-packages/bzrlib/", line 135, in
    self.cleanups, self.func, *args, **kwargs)
  File "/Library/Python/2.6/site-packages/bzrlib/", line 165, in
    result = func(*args, **kwargs)
  File "/Library/Python/2.6/site-packages/bzrlib/", line 1204,
in run
    use_existing_dir=use_existing_dir, no_tree=no_tree)
  File "/Library/Python/2.6/site-packages/bzrlib/", line 142, in
    remember, create_prefix)
  File "/Library/Python/2.6/site-packages/bzrlib/plugins/svn/",
line 447, in push_branch
  File "/Library/Python/2.6/site-packages/bzrlib/", line 1118, in
    lossy, *args, **kwargs)
  File "/Library/Python/2.6/site-packages/bzrlib/plugins/svn/",
line 971, in push
    self._update_revisions(stop_revision, overwrite)
  File "/Library/Python/2.6/site-packages/bzrlib/plugins/svn/",
line 897, in _update_revisions
    self._push(stop_revision, overwrite=overwrite, push_metadata=True)
  File "/Library/Python/2.6/site-packages/bzrlib/plugins/svn/",
line 886, in _push,
  File "/Library/Python/2.6/site-packages/bzrlib/plugins/svn/", line
333, in push_branch
  File "/Library/Python/2.6/site-packages/bzrlib/plugins/svn/", line
354, in push_todo
  File "/Library/Python/2.6/site-packages/bzrlib/plugins/svn/", line
391, in push_revision_series
    project=project, layout=layout)
  File "/Library/Python/2.6/site-packages/bzrlib/plugins/svn/", line
409, in push_revision_inclusive
  File "/Library/Python/2.6/site-packages/bzrlib/plugins/svn/", line
439, in push_single_revision
  File "/Library/Python/2.6/site-packages/bzrlib/plugins/svn/", line
175, in push_revision_tree
    revid = builder.commit(rev.message)
  File "/Library/Python/2.6/site-packages/bzrlib/plugins/svn/",
line 141, in convert
    return unbound(*args, **kwargs)
  File "/Library/Python/2.6/site-packages/bzrlib/plugins/svn/",
line 828, in commit
  File "/Library/Python/2.6/site-packages/bzrlib/plugins/svn/",
line 397, in add_connection
  File "/Library/Python/2.6/site-packages/bzrlib/plugins/svn/",
line 326, in add
    assert not connection.busy, "adding busy connection in pool"
AssertionError: adding busy connection in pool

bzr 2.4.2 on python 2.6.1 (Darwin-10.8.0-x86_64-i386-64bit)
arguments: ['/usr/local/bin/bzr', 'push']
plugins: bash_completion[2.4.2], bzrtools[2.4.0], changelog_merge[2.4.2],
    colo[0.3.0], email[unknown], explorer[1.2.1], extmerge[unknown],
    fastimport[0.11.0dev], git[0.6.6dev], keychain[0.1.0], launchpad[2.4.2],
    loom[2.2.1dev], netrc_credential_store[2.4.2], news_merge[2.4.2],
    pipeline[1.1.0], qbzr[0.22.0dev], rewrite[0.6.2], svn[1.1.0],
    upload[1.0.1dev], weave_fmt[2.4.2], xmloutput[0.8.8]
encoding: 'UTF-8', fsenc: 'utf-8', lang: 'en_US.UTF-8'

*** Bazaar has encountered an internal error.  This probably indicates a
    bug in Bazaar.  You can help us fix it by filing a bug report at
    including this traceback and a description of the problem.

I've tried upgrading to the latest bzr-svn using 'bzr branch lp:bzr-svn
svn' under my ~/.bazaar/plugins directory, but the error remains.

I did a search and found that this error has come up before, but it was
marked resolved - and didn't exactly match my scenario.

Any help here would be greatly appreciated.


Learn from the past. Live in the present. Plan for the future.
jEdit <> - Programmer's Text Editor
Bazaar <> - Version Control for Humans
-------------- next part --------------
An HTML attachment was scrubbed...
URL: <>

More information about the bazaar mailing list