Can't branch projects on Launchpad

Martin Pool martinpool at
Thu Jan 26 00:16:24 UTC 2012

I suspect that you or your isp have an http proxy that is interfering with
the traffic. If you use only ssh you should avoid the problem.
On Jan 26, 2012 9:17 AM, "Dan MacMillan" <danm at>

> Martin,
> I only tried branching a couple of projects on Launchpad and they all
> failed the same way.
> I did as you suggested and branched the project over bzr+ssh and it
> worked.  bzr+ssh is the method we use here to access our repositories as
> well.  We also have some repositories that we can access over HTTPS, and
> they also work here using Bazaar.  It just doesn't like Launchpad + HTTP
> for some reason.
> At any rate, using bzr+ssh is a serviceable workaround.  Thanks for
> assisting me.
> Dan MacMillan
> -----Original Message-----
> From: Martin Packman [mailto:martin.packman at]
> Sent: Wednesday, January 25, 2012 13:55
> To: Dan MacMillan
> Cc: bazaar at
> Subject: Re: Can't branch projects on Launchpad
> On 25/01/2012, Dan MacMillan <danm at> wrote:
> >
> > bzr: ERROR: short readline in the readvfile hunk: 'Bazaar pack format
> > 1 (introduced in 0.18)\r'
> This is a little mysterious, does it happen consistently the same way if
> you try and branch different repositories, to different places? As you
> suspected, I have no problem branching that repo over http. One option, if
> you've not tried it, is to see whether putting a public key on launchpad,
> telling bzr your launchpad user names like it suggested, and branching over
> bzr+ssh has the same issue or not.
> Apart from that, I haven't got any clever ideas.
> Martin
-------------- next part --------------
An HTML attachment was scrubbed...
URL: <>

More information about the bazaar mailing list