Using bzr With a Subversion Repository

Tom Browder tom.browder at
Tue Sep 21 19:44:01 BST 2010

I am venturing into bzr for the first time.  I'm trying to checkout a
branch of my company's subversion repository while using a vpn
connection onto their network.

I have been following steps for bzr-svn in Chapter 8 of the User
Guide, Release 2.2.0 (and I am using that bzr version).

I want to check out the branch at:

URL: svn+ssh://

I command:

$ bzr init-repo bzr-test-repo
$ bzr co svn+ssh://
Initialising Subversion metadata cache in
bzr: ERROR: Not a branch:

I then tried:

$ bzr svn-import
bzr: ERROR: svn+ssh://
appears to contain a branch. For individual branches, use 'bzr

I then tried:

$ cd bzr-test-repo
$ bzr branch svn+ssh://
bzr: ERROR: Not a branch:

Then I tried:

$ bzr co svn+ssh://

and bzr seemed to like that; however, I want to check out the
"Commercial%Value" branch only, can that be done?

I'm sure I'm doing something stupid, but I need some help here.



Thomas M. Browder, Jr.
Niceville, Florida

More information about the bazaar mailing list