bazaar error on repository

Tata Dano dano at i360connect.com
Tue Oct 13 09:16:21 BST 2009


Yeah..you are right. The remote repo is on pack-0.92 format.

I have access on the remote repo so I execute:

bzr upgrade (inside my repo folder) but I got this message instead:

[root at xxxx xxxxxx]# bzr upgrade testdeploy/
bzr: ERROR: The branch format Bazaar-NG meta directory, format 1 is already
at the most recent format.

Any thoughts on this one?

>
> Your local repository in 2a format (default in bzr 2.0+) but your remote
> repo in old format (pack-0.92 maybe). You can ask format of remote repo
> using command:
>
> bzr info -v ftp://...
>
> Upgrading local repo to 2a makes it incompatible with old (non-rich-roots)
> format. You should upgrade your remote repository.
> E.g.
>
> bzr upgrade ftp://...
>
> Ensure all your coworkers using bzr 2.0 or at least 1.17-1.18, otherwise
> they won't access new 2a format of repo.
>
>
>
-------------- next part --------------
An HTML attachment was scrubbed...
URL: https://lists.ubuntu.com/archives/bazaar/attachments/20091013/14742f6b/attachment.htm 


More information about the bazaar mailing list