Failure during remote upgrade

Philippe Lhoste PhiLho at GMX.net
Thu Oct 1 10:12:03 BST 2009


On 01/10/2009 00:01, Barry Warsaw wrote:
> I'm only using the command line sftp, but doing 'cd 
> ~mailman-coders/mailman/3.0' followed by 'ls -la' worked for me.

Mmm, I tried with WinSCP, supposing FileZilla was bad with SFTP, but I have basically the 
same behavior: I seem to be connected, but even a simple 'pwd' typed on the command line 
fails. I connect to bazaar.launchpad.net with my login name and LP password. The clients 
report a connection.

I suppose I can get a Windows command line SFTP client, but I might as well just download 
hitchhiker which seems to be of general usefulness anyway.

In the meantime, I tried again (I am obstinate) a remote upgrade, but this time using the 
SFTP mode, since it seems capable to do stuff lp: protocol cannot... I was successful:

 > bzr upgrade -v sftp://bazaar.launchpad.net/~philho/+junk/Greasemonkey
Connected (version 2.0, client Twisted)
Authentication (publickey) successful!
Secsh channel 1 opened.
[chan 1] Opened sftp connection (server version 3)
starting upgrade of sftp://bazaar.launchpad.net/~philho/%2Bjunk/Greasemonkey/
making backup of sftp://bazaar.launchpad.net/~philho/%2Bjunk/Greasemonkey/.bzr
   to sftp://bazaar.launchpad.net/~philho/%2Bjunk/Greasemonkey/backup.bzr
starting repository conversion
repository converted
finished

So I will delete the backup with hitchhiker and try again in this mode.

Thanks for the help!

-- 
Philippe Lhoste
--  (near) Paris -- France
--  http://Phi.Lho.free.fr
--  --  --  --  --  --  --  --  --  --  --  --  --  --




More information about the bazaar mailing list