List of required packages to get lp:bzr to make on OS X?

Martin Pool mbp at canonical.com
Thu Sep 17 05:57:00 BST 2009


2009/9/16 Bob Tanner <tanner at real-time.com>:
> Here is how I got everything to work.
>
> I removed the python.org's Mac Installer version (2.6.2 as of 09/16/2009)
> this version looks to be build against 10.4's SDK and I could not figure out
> how to change it without a recompile.
>
> Removing the above "exposed" snow leopard's native installed python 2.6.1,
> in retrospect I could have just rearrange my $PATH.
>
> The snow leopard python does calll the 10.6 SDK so I was good, from the
> library, header stand-point.
>
> I used easy_install-2.6 to install pyrex
>
> $ sudo easy_install-2.6 pyrex
>
> The simply did a make in my bzr.dev directory.
>
> $ cd path/to/bzr.bzr
> $ make
>
> All is working now, no warnings.

I'm glad to hear that.  Could you put these tips in some suitable
place on the wiki?

After some discussion on the irc we agreed to make the
missing-extensions warning simpler, and see also
http://bazaarvcs.wordpress.com/2009/09/17/extension-warnings/

-- 
Martin <http://launchpad.net/~mbp/>



More information about the bazaar mailing list