[BUG] bzr-fastimport: ERROR: exceptions.NameError (Was Re: Call for help: Making the move to Bazaar an easier one)

Jari Aalto jari.aalto at cante.net
Mon Aug 17 23:03:43 BST 2009

Jari Aalto <jari.aalto at cante.net> writes:

> Ian Clatworthy <ian.clatworthy at canonical.com> writes:
>> BTW, the recipe for migrating data from tool xxx to Bazaar using
>> bzr-fastimport is now generally:
>>   bzr fast-export-from-xxx project.fi
>>   bzr fast-import project.fi project.bzr
> I think I'm missing something (1.17):
>     $ bzr branch lp:bzr-fastimport /root/.bazaar/plugins/fast_import

Make that

    $ bzr branch lp:bzr-fastimport /root/.bazaar/plugins/fastimport

But then:

    $ bzr fast-export-from-git -v bin.git bin.fi

bzr: ERROR: exceptions.NameError: global name 'source' is not defined

Traceback (most recent call last):
  File "/usr/lib/python2.5/site-packages/bzrlib/commands.py", line 835, in exception_to_return_code
    return the_callable(*args, **kwargs)
  File "/usr/lib/python2.5/site-packages/bzrlib/commands.py", line 1030, in run_bzr
    ret = run(*run_argv)
  File "/usr/lib/python2.5/site-packages/bzrlib/commands.py", line 647, in run_argv_aliases
    return self.run(**all_cmd_args)
  File "/foo/.bazaar/plugins/fastimport/__init__.py", line 653, in run
    fast_export_from(source, destination, 'git', verbose)
  File "/foo/.bazaar/plugins/fastimport/exporters/__init__.py", line 324, in fast_export_from
  File "/foo/.bazaar/plugins/fastimport/exporters/__init__.py", line 237, in generate
    retcode = self.execute(args, outf, cwd=source)
  File "/foo/.bazaar/plugins/fastimport/exporters/__init__.py", line 121, in execute
    note("Executing %s in directory %s ..." % (" ".join(args), source))
NameError: global name 'source' is not defined

bzr 1.17 on python 2.5.4 (linux2)
arguments: ['/usr/bin/bzr', 'fast-export-from-git', '-v', 'bin.git', 'bin.fi']
encoding: 'UTF-8', fsenc: 'UTF-8', lang: 'en_DK.UTF-8'
  fastimport           /foo/.bazaar/plugins/fastimport [0.9dev]
  launchpad            /usr/lib/python2.5/site-packages/bzrlib/plugins/launchpad [1.17]
  netrc_credential_store /usr/lib/python2.5/site-packages/bzrlib/plugins/netrc_credential_store [1.17]
*** Bazaar has encountered an internal error.
    Please report a bug at https://bugs.launchpad.net/bzr/+filebug
    including this traceback, and a description of what you
    were doing when the error occurred.

More information about the bazaar mailing list