[RFC] Plugin property API

Aaron Bentley aaron at aaronbentley.com
Fri Jul 17 14:04:45 BST 2009


-----BEGIN PGP SIGNED MESSAGE-----
Hash: SHA1

Jelmer Vernooij wrote:
> With the current infrastructure the minimum and maximum version of bzr
> that is supported will have to be specified in two places: __init__.py
> (a range of API versions that's supported) and setup.py (a mimimum and
> maximum bzrlib version). Since this information is updated regularly
> (pretty much every bzr version) I'd like to specify it only once, in
> setup.py.

My plugins often don't have setup.py  They often consist of just __init__.py

And bear in mind that plugins may also be modules, instead of packages.
 If so, it's impossible for them to have a setup.py.

> This could then take care of checking the minimum/maximum supported
> versions as declared by the plugin. Unfortunately it would mean an
> extra import per plugin (for the setup file). Would anybody object to
> such a function?

Yes, I'd rather setup.py got the info from __init__.py, instead of the
other way around.

Aaron
-----BEGIN PGP SIGNATURE-----
Version: GnuPG v1.4.9 (GNU/Linux)
Comment: Using GnuPG with Mozilla - http://enigmail.mozdev.org

iEYEARECAAYFAkpgdukACgkQ0F+nu1YWqI3/ngCdGooOrzNi1twK4tZBXejdnDQw
HHMAn2zfyarDs0W7SRXo1iFVL8GgzYCM
=+nUt
-----END PGP SIGNATURE-----



More information about the bazaar mailing list