bzr 1.16, MacPorts and fastimport

Martin Pool mbp at sourcefrog.net
Thu Jul 2 04:43:26 BST 2009


2009/7/1 Lars Hoss <lars at woeye.net>:
> Hi everyone,
>
> first let me thank you for 1.16+ and the new repo format 2a. Bzr feels a
> lot more speedy these days. Kudos to the developers!
>
> I stumbled across minor issues though:
>
> 1) bzr in MacPorts is a outdated. I provided a patch for 1.16 some days
> ago but now that 1.16.1 is out this patch has become outdated already :)

Thanks, that's great.

>
> 2) After installing it myself I tried to convert a git repo to bzr with
> fastimport. The first attempt failed because branch_updater.py crashed. On
> my box the issue was that line 92 uses osutils, but line 21 doesn't import
> it? So my fix was to change line 21 to:
>
> from bzrlib import bzrdir, errors, osutils

Thanks, I fixed this is trunk.

> 3) I tried to import my git repo into a shared bzr repo using the new 2a
> format. The good thing was that fastimport imported all my git branches
> into different repos inside my shared repo. On the downside the format of
> each repo was "unnamed". Shouldn't it be 2a? Unfortunately there's no way
> to tell fastimport which format to use for each repo either. Or maybe
> these are 2a repos but "unnamed" is just a bit confusing?

Yes, calling it "unnamed" is confusing --
https://bugs.edge.launchpad.net/bzr/+bug/202083

-- 
Martin <http://launchpad.net/~mbp/>



More information about the bazaar mailing list