Better name for dpush wanted

Ben Finney ben+bazaar at
Fri Apr 17 03:17:06 BST 2009

Ian Clatworthy <ian.clatworthy at> writes:

> FWIW, the best suggestion I'd seen/heard so far is
> calling it "push-out".

I'm against adding another command; conceptually, it's the same
operation as ‘push’ with a different option.

My favourite is ‘push --foreign’.

Alternatively, if there's an identifiable “foo” that normal push has but
this push doesn't have, and which makes sense for the user, then ‘push
--no-foo’ is also okay.

 \      “The most common way people give up their power is by thinking |
  `\                               they don't have any.” —Alice Walker |
_o__)                                                                  |
Ben Finney

More information about the bazaar mailing list