bzr ci: NoSuchFile obsolete_packs

John Arbash Meinel john at
Mon Apr 13 17:59:17 BST 2009

Hash: SHA1

Christophe TROESTLER wrote:
> Hi,
> After entring the commit message in my editor, bzr replied with
> aborting commit write group: NoSuchFile(No such file: u'/home/trch/software/OCam
> l/syntax-ext/pa-do/.bzr/repository/obsolete_packs/': [Errno 2] No such file or d
> irectory: '/home/trch/software/OCaml/syntax-ext/pa-do/.bzr/repository/obsolete_p
> acks/')
> bzr: ERROR: No such file: u'/home/trch/software/OCaml/syntax-ext/pa-do/.bzr/repo
> sitory/obsolete_packs/': [Errno 2] No such file or directory: '/home/trch/softwa
> re/OCaml/syntax-ext/pa-do/.bzr/repository/obsolete_packs/'
> and the commit was not performed.  This is not a big deal as I tried
> again to commit and it worked flawlessly but this is not a nice user
> experience.  BTW, this is a branch in a shared repository.
> Regards,
> ChriS

'obsolete_packs' is a directory which we create during "bzr init" and we
expect to exist always. We never delete it, so if it has disappeared,
something else has removed it. (The user, the OS, etc.)

Having a (possibly empty) directory deleted underneath us isn't
particularly nice. I think we've done some work to auto-create it if it
doesn't exist, but we shouldn't have to.

My guess is that someone deleted the directory as part of a "cleanup"
and didn't realize that we say "you can delete things *inside*
obsolete_packs, but you should never delete the directory itself."


Version: GnuPG v1.4.9 (Cygwin)
Comment: Using GnuPG with Mozilla -


More information about the bazaar mailing list