[MERGE] Skip unnecessary work in BzrBranch._basic_push.
v.ladeuil+lp at free.fr
Tue Sep 16 07:29:02 BST 2008
>>>>> "Andrew" == Andrew Bennetts <andrew at canonical.com> writes:
Andrew> I do think it deserves a new module though; there's
Andrew> nowhere else that tests this particular combination
Andrew> of factors (remote objects + builtin cmd_* +
Andrew> measuring round trips),
bzrlib/tests/commands contains tests using cmd_* objects and
measuring the connections made (it counts as round trips :).
But 'commands' is a bad name.
Andrew> So how about if I rename the module to something like
Andrew> test_remote_branch or test_remote_push? As we write
Andrew> more tests in this area we can always rename and
I think we want effort tests outside the remote area too so how
about creating tests/effort, create a 'remote' directory there
and rename 'tests/commands' to 'tests/effort/connection' ?
More information about the bazaar