Loggerhead 1.6: installation problems

Marius Kruger amanic at gmail.com
Thu Sep 4 21:36:29 BST 2008

2008/9/4 John Arbash Meinel <john at arbash-meinel.com>

> Marius Kruger wrote:
> > Hi,
> >
> > I tried the loggerhead 1.6 and 1.6.1 with bzr 1.6.1rc1 and 1.5
> > I can start the server with `$ ./serve-branches /stuph/projects`
> > The server comes up and I can browse the file system, but as soon as
> > click on a bzr branch, I get
> > `Internal Server Error` on the browser
> > and the following stack trace on the backend.
> ...
> >     graph.iter_ancestry([last_revid]) if value is not None))
> > AttributeError: 'Graph' object has no attribute 'iter_ancestry'
> >
> So... Graph.iter_ancestry has existed since bzr 1.3 (and hasn't changed
> much since then.)
> I would actually guess that you have an old bzrlib lying around
> somewhere (possibly installed site-wide?).

I don't know how you guessed it, but you hit the nail right on the head.
It turns out that I had a bzrlib v1.1 in my
/usr/lib/python2.5/site-packages  (version_info = (1, 1, 0, 'dev', 0))
which I must have installed with apt-get or setup.py or something when I
last installed kubuntu on my laptop.
This is strange because as far as I know, `bzr --version` used to show the
bzrlib I expected.
I wonder if there is a way to detect rogue bzrlibs contaminating the
This might also explain some weird behaviour I had with other tools, and I'd
have to check some bugs I submitted.

I was starting to loose hope with Loggerhead, but now it works beautifully!
Its just in time too, as I need to get it installed for our company so that
we can use bzr more (with gforge :( ).

best regards

ps. the kiss think is just a figure of speech to show how happy I am right
-------------- next part --------------
An HTML attachment was scrubbed...
URL: https://lists.ubuntu.com/archives/bazaar/attachments/20080904/68a31f23/attachment.htm 

More information about the bazaar mailing list