[MERGE] Update to bzr.dev.
Robert Collins
robertc at robertcollins.net
Tue Jun 17 23:56:34 BST 2008
On Tue, 2008-06-17 at 15:20 -0500, John Arbash Meinel wrote:
>
> | + def _iter_inventory_xmls(self, revision_ids):
> | + keys = [(revision_id,) for revision_id in revision_ids]
> | + stream = self.inventories.get_record_stream(keys,
> 'unordered', True)
> | + texts = {}
> | + for record in stream:
> | + if record.storage_kind != 'absent':
> | + texts[record.key] = record.get_bytes_as('fulltext')
> | + else:
> | + raise errors.NoSuchRevision(self, record.key)
> | + for key in keys:
> | + yield texts[key], key[-1]
> | +
> |
> | Can we rename this to _iter_inventory_xmls; making apis that assume
> they're xml
> | is not so good when we may want to go away from that.
>
> I think you are wanting a different name, since it *is* called
> iter_inventory_xmls. Maybe "iter_inventory_texts" or
> "iter_serialized_inventories".
The thing is, they are xml's that are being asked for :P
-Rob
--
GPG key available at: <http://www.robertcollins.net/keys.txt>.
-------------- next part --------------
A non-text attachment was scrubbed...
Name: not available
Type: application/pgp-signature
Size: 189 bytes
Desc: This is a digitally signed message part
Url : https://lists.ubuntu.com/archives/bazaar/attachments/20080618/037ed493/attachment.pgp
More information about the bazaar
mailing list