API breakages - file bugs / update HACKING.txt ?

Aaron Bentley aaron at aaronbentley.com
Thu May 22 18:15:47 BST 2008


-----BEGIN PGP SIGNED MESSAGE-----
Hash: SHA1

Jelmer Vernooij wrote:
> It's not just new mandatory arguments., it's also public APIs
> disappearing without deprecation. For example, the public constructor
> of KnitVersionedFile lost two arguments in 1.4.

This is true, but before doing that, Robert posted a message titled "api
break for 1.4..." and requested feedback on whether that break was
acceptable.  So you could have said "no" at that point.

I think that we should not generally remove things without deprecation.
 When we do, we ought to confirm it with the community like Robert did.

Aaron
-----BEGIN PGP SIGNATURE-----
Version: GnuPG v1.4.6 (GNU/Linux)
Comment: Using GnuPG with Mozilla - http://enigmail.mozdev.org

iD8DBQFINapD0F+nu1YWqI0RAgdhAJ9TxvCAeWGd9/4Y8efwBDUYCsOC3gCePGIz
sZmarN4+pubrOT+BvN/0YGA=
=1/DP
-----END PGP SIGNATURE-----



More information about the bazaar mailing list