qdiff freezing on a single revision

Joseph Wakeling joseph.wakeling at webdrake.net
Fri Mar 21 16:31:38 GMT 2008

Hello all,

I'm having a problem with the qbzr command bzr qlog.

I recently merged in a revision from a friend's branch on a mutual
project.  The merged-in revision deletes quite a large number of files
and modifies a few others.

When I attempted to run bzr qdiff after the merge, the command seemed
just to hang---no window opened, nor could I ctrl-C kill it.

bzr diff or cdiff worked fine, and seeing nothing wrong with the
changes, I committed them.

Now, if I run bzr qlog, and attempt to view the qdiff of this revision,
it again hangs.  Looking at the qdiff of any other revision prior or
subsequent to the merge works fine.

I'm unsure if this is a duplicate of bug 174964:

... or whether it's something different.  I note that it's a quite small
tree I'm working with, it's a new project with few revisions (the merge
was no. 17, the merged revision 15.1.1) and about 140 files.

Can anyone advise?


    -- Joe

More information about the bazaar mailing list