CVSROOT Conversion

Tom Browder tom.browder at
Wed Jan 2 17:35:31 GMT 2008

I just installed bzaar on a linux box and want to try to convert a
large CVS repository to try out bazaar.

My CVSROOT is "/usr/local/cvsroot".

I made a new directory for the conversion: "/usr/local/bzr_cvsroot" (I
did not use "bzr init-repository").

I executed the following to convert all my modules:

  cd /usr/local
  bzr cvsps-import cvsroot . bzr_cvsroot

After a long time, I got an apparently good completion.  I browsed
around the new directory and can find all my rtags--good!  And I find
all my modules referenced in "staging/ROOT.dump".  Now how can I
checkout the head (no branch) of module X with bzr?

I've tried:

  bzr checkput /usr/local/bzr_csvsroot/X

without success.  I've also tried inserting various subdirs of
"bzr_cvsroot" without success.

I'm sure I'm missing something obviousor I've done something stupid,
but a kick would help.



Tom Browder
Niceville, Florida

More information about the bazaar mailing list