[MERGE] Add a smart method method that can pull a set of revisions in a single request

Andrew Bennetts andrew at canonical.com
Tue Sep 4 07:23:26 BST 2007

Aaron Bentley wrote:
> Hash: SHA1
> Andrew Bennetts wrote:
> >> This looks pretty good.  I still don't see a direct test for 
> >> self.item_keys_introduced_by, though.  Without that, there's no 
> >> justification for implementing it on RemoteRepository.
> > 
> > I've added a test for this.
> Thanks.
> bb:approve


> > I've tidied up the long lines that I can; unfortunately the rather long class
> > name makes it hard to avoid in a couple of spots. Let me know if you have
> > specific suggestions to fix these,
> Well, there's always the option of changing the class name to something
> shorter.

That's true.  But I'd either have to rename the method used on the wire, or
break the existing naming convention for request handlers to do this.

> The long line in test_is_incompatible_different_format_both_remote looks
> trivial to fix.

Oops, yes.  Thanks.


More information about the bazaar mailing list