[MERGE] InterTree.compare doesn't pass require_versioned on correctly

Marius Kruger amanic at gmail.com
Sun Jul 29 00:40:07 BST 2007

  While working on a patch for bug #11665,
  and doing some debugging, I realised that
  InterTree.compare and delta._compare_trees did not pass its
  parameter require_versioned on correctly.

  This bundle attempts to correct it, and adds a test so that is
  doesn't happen again!

Because I don't trust Version Control Systems with less than 6953 unit tests.
-------------- next part --------------
A non-text attachment was scrubbed...
Name: InterTree_ignores_param.patch
Type: text/x-patch
Size: 5685 bytes
Desc: not available
Url : https://lists.ubuntu.com/archives/bazaar/attachments/20070729/c7592a96/attachment.bin 

More information about the bazaar mailing list