"submit" command naming - just "bundle" preferred?
aaron.bentley at utoronto.ca
Sun Jul 22 18:59:23 BST 2007
-----BEGIN PGP SIGNED MESSAGE-----
Ian Clatworthy wrote:
> Aaron Bentley wrote:
>> I'm loathe to call it "send" before we make it possible to send.
> That's a fair argument, but submit fails that same test, yes?
Well, submit is more vague about mechanism to me, so the fact that it
doesn't email the submission causes me less cognitive dissonance.
> My primary concern right now is UI churn. I'm not keen on revising the
> documentation several times as the recommended commands change 3 times
> in 3 releases (worse case):
> * 0.18 = bundle or merge-directive
> * 0.19 = submit
> * 0.20 = send
I count two *changes*:
- - bundle/merge-directive -> submit
- - submit -> send
> I feel we ought to call submit send now or agree to leave it as submit
I'm tempted to call it submit, because it leaves the door open to other
forms of submission, like XMLRPC. Plus we can then introduce a
"dominate" command :-)
-----BEGIN PGP SIGNATURE-----
Version: GnuPG v1.4.6 (GNU/Linux)
Comment: Using GnuPG with Mozilla - http://enigmail.mozdev.org
-----END PGP SIGNATURE-----
More information about the bazaar