[RFC] Deprecation warnings considered harmful

Robert Collins robertc at robertcollins.net
Fri Jun 22 05:57:27 BST 2007


During a discussion with Aaron about the version compatability api I
proposed, he noted that one of the reasons for bzrtools strict
compatibility requirement is to avoid users complaining about
deprecation warnings when in fact its just that bzrtools needs an
upgrade.

We could address this (as deprecations are meant to be compatible) by
disabling deprecations in the normal use of bzr from the command line.
External library users, and our test suite, will still benefit from them
- we'd want run_bzr to keep them enabled so that we catch them in tests.

Thoughts?
-Rob
-- 
GPG key available at: <http://www.robertcollins.net/keys.txt>.
-------------- next part --------------
A non-text attachment was scrubbed...
Name: not available
Type: application/pgp-signature
Size: 189 bytes
Desc: This is a digitally signed message part
Url : https://lists.ubuntu.com/archives/bazaar/attachments/20070622/22a0f803/attachment.pgp 


More information about the bazaar mailing list