[MERGE] bzr rm should delete the working file (Bug #82602)
John Arbash Meinel
john at arbash-meinel.com
Fri Apr 13 21:37:37 BST 2007
Marius Kruger wrote:
...
Actually, I prefer "run_bzr" to run_bzr_captured....
run_bzr is just a wrapper around _captured, which allows you to supply:
run_bzr('params', 'to', 'bzr')
rather than
run_bzr_captured(['params', 'to', 'bzr'])
If only because it is less to type and keep track of.
> ok I'll convert to run_bzr_captured,
> but 'self.runbzr' seemed more suited to lazy people like me...
> [DONE]
>
> * these tests follow this pattern:
> (out, err) = self.run_bzr_captured(['remove', '--keep', 'a'])
> self.assertEquals(out.strip(), "")
> self.assertEquals(err.strip(), "removed a")
> which we might want to do better:
> self.run_bzr_captured(['remove', '--keep', 'a'], out_regex='',
> err_regex="removed a")
> also can't I make it like runbzr, to auto expand a sting?
> (your probably gona say no as you don't like isinstance magic :(
We are more okay with testing magic, as long as it ends with easy to
understand tests.
We have "(out, err) = self.run_bzr_error([regex1, regex2], 'command',
'to', 'run')"
Does that fit what you want?
> ...
> I'm still busy with the rest, but will get it done asap.
>
Ok. Again, we'd like to see this land by Monday. So ping me if you need
some help. I may not be around a whole lot over the weekend, but other
people will be.
John
=:->
More information about the bazaar
mailing list