baz-import-branch: unexpected conflicts

Ben Finney bignose+hates-spam at
Fri Aug 25 23:55:30 BST 2006

John Arbash Meinel <john at> writes:

> Ben Finney wrote:
> > [Replies only to the discussion forum please, I subscribe via NNTP.]
> > 
> > I'm trying to convert a branch from baz to bzr, but it's failing with
> > the following output.
> > 
> > =====
> > $ bzr baz-import-branch ben at
> > importing ben at into /home/bignose/Projects/websites/
> > Cleaning up
> > bzr: ERROR: pybaz.errors.ExecProblem: baz exited with code 2 (expected exit code 0)
> > argv: 'get', 'ben at', '/home/bignose/Projects/websites/baz2bzr--86oZQ/rd'
> > * error report
> > * Scanning for full-tree revision: ....
> > * from revision library (linking): ben at
> > * Applying 2 revisions (in reverse): ..****************************************************
> ^--- So this is actually what is causing problems. It is reverse
> applying the changes from patch-4 back to patch-2. And isn't patch-4 the
> one that has a content change? (A file changed into a symlink, or vice
> versa).

With further help via IRC from j-a-meinel, I tried this again on
another machine and it worked fine. I then tried it on the same
machine, cleaning out the revision library first -- and it worked

So there seems to be some kind of trouble with baz and revlibs, and
when the branch doesn't exist in the revlib, there's no problem (in
this case).

For the purpose of getting what I wanted, that's a viable
workaround. Does anyone want me to diagnose further?

 \          "When we call others dogmatic, what we really object to is |
  `\        their holding dogmas that are different from our own."  -- |
_o__)                                                   Charles Issawi |
Ben Finney

More information about the bazaar mailing list